Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

99 Chevy Suburban 5.7L Engine Won't Accelerate


  Email This Post



NE'sFinest
New User

Oct 10, 2013, 8:17 AM

Post #1 of 7 (2438 views)
99 Chevy Suburban 5.7L Engine Won't Accelerate Sign In

I have a 1999 Chevy Suburban K1500 4 wheel drive. It has a 5.7 liter engine and has 360,000 miles. I recently had a fuel pump put in last year. It is now running sluggish when I accelerate it will not go. This happens after it seems to warm up about 15 minutes of driving. I just replaced the fuel filter thinking that it may have been plugged up but it is still running poorly. When I put the fuel pressure gauge on it, it read 61-62 during start up and then dropped down to 57-59 (pulsates rapidly) after I started it. Any advice would be greatly appreciated.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Oct 10, 2013, 8:36 AM

Post #2 of 7 (2426 views)
Re: 99 Chevy Suburban 5.7L Engine Won't Accelerate Sign In

The fuel pressure seems to be fine. Have it scanned for any stored trouble codes.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



NE'sFinest
New User

Oct 10, 2013, 8:53 AM

Post #3 of 7 (2422 views)
Re: 99 Chevy Suburban 5.7L Engine Won't Accelerate Sign In

Thank you for the quick response, I did have it scanned and there is nothing wrong but the oxygen sensor. Can this affect how the car runs?


nickwarner
Veteran / Moderator
nickwarner profile image

Oct 10, 2013, 11:27 AM

Post #4 of 7 (2412 views)
Re: 99 Chevy Suburban 5.7L Engine Won't Accelerate Sign In

What was the code?


Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Oct 11, 2013, 4:41 AM

Post #5 of 7 (2395 views)
Re: 99 Chevy Suburban 5.7L Engine Won't Accelerate Sign In


Quote
It has a 5.7 liter engine and has 360,000 miles.



Is that 360K on the original engine?





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.


NE'sFinest
New User

Oct 11, 2013, 6:32 AM

Post #6 of 7 (2386 views)
Re: 99 Chevy Suburban 5.7L Engine Won't Accelerate Sign In

Yes it is on the original engine


Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Oct 11, 2013, 3:24 PM

Post #7 of 7 (2383 views)
Re: 99 Chevy Suburban 5.7L Engine Won't Accelerate Sign In

You should do a compression check to see what the mechanical condition of the engine is. Be sure the battery is fully charged, the fuel and ignition is disabled, and the throttle is wide open when you do your test.





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap