Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

help me


  Email This Post



woody
Novice

Aug 13, 2008, 12:27 PM

Post #1 of 18 (2181 views)
help me Sign In

o.k. peeps ya gotta help me out here. I drive a 93 Chevy Astro. A couple of weeks ago I was driving to work when it died on me. So I got it started, drove a little further, died again. Before all this every now and then when i would start it, the engine would rev up w/o me touching the gas. So now when i do start it, the engine revs then dies. Today i started it 3 times it only acted up once.Crazy So what's the deal??? My hubby thinks maybe the idle air speed motor? We welcome your thoughts.


Double J
Veteran / Moderator
Double J profile image

Aug 13, 2008, 1:13 PM

Post #2 of 18 (2179 views)
Re: help me Sign In

Check engine light on or does it come on while driving/running?
Have the system scanned for any trouble codes first.(Autozone/parts chains do this for free)
Have the fuel pressure checked using a fuel pressure gauge.( Autozone rents gauges for this)
Thats a starting point...

Post back any findings...


Jim


Guest
Anonymous Poster

Aug 13, 2008, 1:31 PM

Post #3 of 18 (2178 views)
Re: help me Sign In

check engine light only comes on when starting. Hubby hooked up scanner, said o.k. to drive.


way2old
Veteran / Moderator
way2old profile image

Aug 13, 2008, 3:54 PM

Post #4 of 18 (2173 views)
Re: help me Sign In

I agree with Jim on having the fuel pressure checked. Post back the pressures for us.



Being way2old is why I need help from younger minds


Jeff Norfolk
Enthusiast
Jeff Norfolk profile image

Aug 13, 2008, 8:20 PM

Post #5 of 18 (2168 views)
Re: help me Sign In

I just repaired a 98 Astro today with a similar problem. Die while running, restart fine then die again a bit later. Hooked up my pressure gauge and drove around till it dies. It lost fuel pressure right before it would die. Replaced fuel pump and all is well. Fuel filter also of course.
Jeff


woody
Novice

Aug 14, 2008, 4:18 PM

Post #6 of 18 (2156 views)
Re: help me Sign In

how do you tell which/ throttle postion sensor/ idle air speed control motor is bad. does not act like fuel prob is random also rpms jump without using throttle.

woody


Guest
Anonymous Poster

Aug 15, 2008, 4:12 PM

Post #7 of 18 (2141 views)
Re: help me Sign In

why then would the engine idle speed jump on its own? if the prob was fuel press?


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Aug 15, 2008, 4:25 PM

Post #8 of 18 (2138 views)
Re: help me Sign In


In Reply To
why then would the engine idle speed jump on its own? if the prob was fuel press?



Many vehicles will try to raise idle so cover loads or a close stall which could result in reving up for a moment while it's confused.

Low fuel pressure could lower idle before quitting completely and the frustrated computer can only make so many adjustments with a problem at hand. Knowing that fuel pressures are in spec at least could rule that out,

T



Guest
Anonymous Poster

Aug 16, 2008, 6:51 AM

Post #9 of 18 (2130 views)
Re: help me Sign In

what is the specs on the fuel pump? how any psi?. I only asked these questions with doubts due to the nature of it when it fails.am a mechanic for 12 yrs so far sure acts like electrical failure. but would appreciate the specs for testing fuel pressure i guess i should rule it out. thank u for the suggestion


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Aug 16, 2008, 7:16 AM

Post #10 of 18 (2126 views)
Re: help me Sign In

Me bad - I'm not certain so quick for 93 Astro. I think 53-59 is the spec. Some, especially GMs won't behave with just a pound or two under spec! See if the guys have a more exact range for the norms. Remember that when engine is running you are operating with higher voltages than just with KOEO situation which still needs to be adequate,

T



(This post was edited by Tom Greenleaf on Aug 16, 2008, 7:18 AM)


way2old
Veteran / Moderator
way2old profile image

Aug 16, 2008, 8:32 AM

Post #11 of 18 (2122 views)
Re: help me Sign In

Alldatapro has vin W listed at 55 to 61 psi.
If it is vin Z the pressure is 9-13 psi.
So now we need to know which engine you have.



Being way2old is why I need help from younger minds

(This post was edited by way2old on Aug 16, 2008, 8:36 AM)


woody
Novice

Sep 5, 2008, 4:12 PM

Post #12 of 18 (2081 views)
Re: help me Sign In

it is a w motor has approx 52 58 psi woody


woody
Novice

Sep 5, 2008, 4:14 PM

Post #13 of 18 (2080 views)
Re: help me Sign In

fuel pressure is 52 to 58 psi when it dies never loses pressure runs alot of the time about 50 -52psi


woody
Novice

Sep 5, 2008, 4:15 PM

Post #14 of 18 (2079 views)
Re: help me Sign In

check eng light only on when starting have scanned no codes also fuel pres at 50 -58 psi never loses pressure


woody
Novice

Sep 5, 2008, 4:17 PM

Post #15 of 18 (2078 views)
Re: help me Sign In

have also replaced throttle pos sensor and idle air control valve no changes


Guest
Anonymous Poster

Sep 5, 2008, 4:29 PM

Post #16 of 18 (2075 views)
Re: help me Sign In

when checking fuel pres it will jump up when throttling up when u let of will drop to about 48 psi then right back to 50-54psi approx


Guest
Anonymous Poster

Sep 5, 2008, 4:38 PM

Post #17 of 18 (2073 views)
Re: help me Sign In

just to let u know last 5 or six replies are me woody and i have also replaced fuel filter


Guest
Anonymous Poster

Sep 21, 2008, 4:30 PM

Post #18 of 18 (1960 views)
Re: help me Sign In

thought i would let u know i fixed the problem it was electrnic ign module.I bet none of u thought of that HuH?????? thankx for the help






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap