Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

Rough Idle.....Please help!!!!


  Email This Post



danye6969
Novice

Oct 8, 2010, 8:46 PM

Post #1 of 5 (1244 views)
Rough Idle.....Please help!!!! Sign In

Smile So I have a 99 Chevy lumina 110K in miles.....well since I had the car I got a tune up, fuel filter, MAF sensor, fuel pump, new coils and last but not least the most recent a new egr valve. So to make a long story short I was having trouble with the car cutting off on me sometimes so I took it to Goodyear and they ran some tests and they came back with the conclusion I needed a new fuel pump (reason why it would shut off sometimes) and also a new egr valve (reason for the rough idle) so now it doesn't cut off on me now but even though I replaced the egr valve i still have a slight rough idle. Like I can feel it in the brake petal when I'm stopped at a light, etc. and I can hear the car just a little def. not how I want it to sound but not real loud. Please help what could possibly be the issue now. Thanks


speed
User

Oct 10, 2010, 12:43 PM

Post #2 of 5 (1233 views)
Re: Rough Idle.....Please help!!!! Sign In

i noticed you didnt include spark plugs and wires in your tune up. try those and see if that helps.





GM ASEP 26 SCC Milford ASE certified in Brakes and Electrical on Thursday April 5th 2012


danye6969
Novice

Oct 10, 2010, 12:47 PM

Post #3 of 5 (1228 views)
Re: Rough Idle.....Please help!!!! Sign In

Smile sry but yeah tune up included plugs, wires, air and fuel filter and basically the whole tune up kit. Also I noticed today that when I put my foot on the break I can feel something basically the rough idle.


Sidom
Veteran / Moderator
Sidom profile image

Oct 10, 2010, 5:48 PM

Post #4 of 5 (1223 views)
Re: Rough Idle.....Please help!!!! Sign In

Is the check engine light on & if so, what are the codes.........


danye6969
Novice

Oct 10, 2010, 7:49 PM

Post #5 of 5 (1213 views)
Re: Rough Idle.....Please help!!!! Sign In

No check engine ugh im not sure what is the issue






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap