Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

2010 malibu shaking at 55+mph


  Email This Post



jmarshall01
Novice

Aug 7, 2013, 8:47 AM

Post #1 of 7 (1356 views)
2010 malibu shaking at 55+mph Sign In

2010 Chevy Malibu LTZ 4 cylinder with 58k miles
After changing the hub caps the car "shakes" when going over 55 mph. The "shake" feels like its cutting out, like a vacuum hose leak or a bad O2 sensor ("shaking" is not the alignment). The check engine light came on, took it up to auto zone and had it checked and was told the O2 sensor was giving "rich" codes and that I more than likely got some bad gas. They reset the check engine light and stayed off for 2 days. Today as soon as I hit 55 mph the car started "shaking" and sure enough the light came on. The "shaking" started right after I had put the new hub caps on the car (the new hub caps are the exact same ones I was replacing). What could this be caused from? How can I check the vacuum hoses without taking it to a repair shop? Suggestions please! Thanks!


Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Aug 7, 2013, 9:45 AM

Post #2 of 7 (1342 views)
Re: 2010 malibu shaking at 55+mph Sign In

When the vehicle is shaking, put the transmission into neutral. While coasting see if the shake is still there.

Have the computer scanned again and write down the trouble code numbers.





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.


jmarshall01
Novice

Aug 7, 2013, 12:41 PM

Post #3 of 7 (1330 views)
Re: 2010 malibu shaking at 55+mph Sign In

About to head out now and try that, thanks.


jmarshall01
Novice

Aug 7, 2013, 4:11 PM

Post #4 of 7 (1322 views)
Re: 2010 malibu shaking at 55+mph Sign In

While in neutral the car still "shook" until the speed dropped below 53 mph. I went to Advanced Auto Parts this time; same "rich" codes (sorry I forgot to write them down) and was told that it was bad gas again. They turned the check engine light off and I put some type of fuel cleaner in the tank.


Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Aug 7, 2013, 4:39 PM

Post #5 of 7 (1316 views)
Re: 2010 malibu shaking at 55+mph Sign In

The shaking probably isn't something caused by the engine. You could have an imbalance in the wheels that came about when you changed your hubcaps. You could remove the hubcaps and see if your vibration goes away.

The rich code could be P0172. It would have to be troubleshoot to determine why that code is popping up.





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.


jmarshall01
Novice

Aug 7, 2013, 4:47 PM

Post #6 of 7 (1311 views)
Re: 2010 malibu shaking at 55+mph Sign In

I will try. Thanks!


jmarshall01
Novice

Aug 9, 2013, 3:26 PM

Post #7 of 7 (1299 views)
Re: 2010 malibu shaking at 55+mph Sign In

Car still "shakes" without the hub caps. Fuel cleaner and new gas hasn't stopped it either. I'm going to take it to get serviced at a shop. Thanks for your help. I'll let you know the outcome. Thanks again!






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap