Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

2000 blazer


  Email This Post



Billy
Anonymous Poster
billy.gcpi@fuse.net

Jul 10, 2006, 9:58 AM

Post #1 of 4 (2482 views)
2000 blazer Sign In

I have a 2000 chevy blazer with auto climate control which stopped working alltogether the ac compressor runs all the time (cycles) no fan, the controls to change the vents (floor,defrost,dash)don't work, rear defog does not work,
and temp doesn't change. All the fuses are good also. Is there any help for this?
Thanks


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jul 10, 2006, 6:44 PM

Post #2 of 4 (2466 views)
Re: 2000 blazer Sign In

???? It's interesting that the compressor gets power with this problem. The rear window defroster should be totally separate????

Fuses may look good but do they have any power to them?

Just a shot in the dark but this may be a problem with getting power to the fuse box, and maybe a problem with the control head to the climate control.

For now I would chase 12V power with a test light, T



Guest
Anonymous Poster
snk404@optonline.net

May 13, 2009, 6:07 PM

Post #3 of 4 (2026 views)
Re: 2000 blazer Sign In

I have the exact same problem. Please let me know if you solve this problem


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

May 14, 2009, 8:31 AM

Post #4 of 4 (2022 views)
Re: 2000 blazer Sign In

Hey sport! This thread is 3 years old - sign in as post your exact vehicle with the question(s) you need help with would help us help you,


T







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap