Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




Overdrive problem ?? on Buick Regal 2003


  Email This Post



rcl
New User

Jul 30, 2008, 4:35 PM

Post #1 of 1 (1680 views)
Shortcut
Overdrive problem ?? on Buick Regal 2003 Sign In

My 2003 Buick Regal has 96k miles. The car was fine, but had "sat" for a few weeks, with me only driving it about once a week (gas hog compared to my wife's car!)

Then, I drove it a week or so ago, and noticed problems. The car is fine except when I really push the pedal and try to do hard acceleration. I am 99% sure it only happens when I am putting the car into overdrive...

What happens is my tach goes way up, I get no speed (I'm in neutral basically), and I hear a clicking or tapping sound at a moderate tempo of maybe 2 or 3 clicks as second. I take off the gas, give it low to moderate gas, and I'm fine.

I have been trying to diagnose this myself and have so far weeded out a lot of "red herrings", and now I am pretty certain that it's a problem with the transmission going in to overdrive. I was initially worried that it was some kind of general transmission slippage, but it ONLY happens when I kick to very high RPM's so I don't think that's the case. I added a bottle of the Lucas treatment which of course did nothing.


I saw something about this on specific cars where the problem is the "end clutch" warping or going bad, and you open up the tranny, take it out, and replace the bad end clutch. Does this sound like it could be the culprit? What else could be going on here?


I am trying to avoid taking this to a shop because I have another perfectly driveable car (because my wife is pregnant and not working), and because I am pretty short on cash (same reason)... Is it reasonable for a careful person with only light auto experience to do this work at home?


Thanks,

Robert




Overdrive problem ?? on Buick Regal 2003


  Email This Post
 
 






Latest Forum Post

I vacuumed the system and it seemed to be holding, but did not last overnight. ...


So I just bought a 2001 Volkswagen GTI and it seems sluggish. and the engine sh...


Okay folks first off I'm new to this forum I have searched and haven't really fo...


1994 Ford Taurus 3.8 L EFI 6 Cyl 205,000 miles I bought the car about 6 months ...


2002 ford windstar 3,8 160000 ok so i just replaced the shift tube assb. and no...


I am an EMT and recently purchased flashing lights to install in my personal veh...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics