Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




Overdrive problem ?? on Buick Regal 2003


  Email This Post



rcl
New User

Jul 30, 2008, 4:35 PM

Post #1 of 1 (1544 views)
Shortcut
Overdrive problem ?? on Buick Regal 2003 Sign In

My 2003 Buick Regal has 96k miles. The car was fine, but had "sat" for a few weeks, with me only driving it about once a week (gas hog compared to my wife's car!)

Then, I drove it a week or so ago, and noticed problems. The car is fine except when I really push the pedal and try to do hard acceleration. I am 99% sure it only happens when I am putting the car into overdrive...

What happens is my tach goes way up, I get no speed (I'm in neutral basically), and I hear a clicking or tapping sound at a moderate tempo of maybe 2 or 3 clicks as second. I take off the gas, give it low to moderate gas, and I'm fine.

I have been trying to diagnose this myself and have so far weeded out a lot of "red herrings", and now I am pretty certain that it's a problem with the transmission going in to overdrive. I was initially worried that it was some kind of general transmission slippage, but it ONLY happens when I kick to very high RPM's so I don't think that's the case. I added a bottle of the Lucas treatment which of course did nothing.


I saw something about this on specific cars where the problem is the "end clutch" warping or going bad, and you open up the tranny, take it out, and replace the bad end clutch. Does this sound like it could be the culprit? What else could be going on here?


I am trying to avoid taking this to a shop because I have another perfectly driveable car (because my wife is pregnant and not working), and because I am pretty short on cash (same reason)... Is it reasonable for a careful person with only light auto experience to do this work at home?


Thanks,

Robert




Overdrive problem ?? on Buick Regal 2003


  Email This Post
 
 






Latest Forum Post
Hi, Ii have problem with my chevy cruze 2011, my car just 37000km. Before 2 week...
Hi, I am not car savvy. I have a 2003 Honda CRV, and the rear windshield wiper d...
1963 FORD Falcon / installed new tank and sending unit. Gauge shows past full an...
Re: 2000 Buick Century 3.1L 120,000m - I‘m having problems replacing the ...
Actually the only way I could get any pedal at all (and enough pressure to turn...
OK, so I need to reopen this thread and take back my kudos from yesterday, sorry...

Feed Button


Used Car Search
Used Car Price Ranges:
Under $5,000
$20,000
$35,000

$10,000
$25,000
$40,000
$15,000
$30,000
$45,000
Over $45,000
Search used Cars By Manufacturers:
Used Acura
Used Audi
Used BMW
Used Buick
Used Cadillac
Used Chevrolet
Used Chrysler
Used Dodge
Used FIAT
Used Ford
Used GMC

Used Honda
Used Hyundai
Used Infiniti
Used Jaguar
Used Jeep
Used Kia
Used Land Rover
Used Lexus
Used Lincoln
Used Mazda
Used Mercedes-Benz

Used MINI
Used Mitsubishi
Used Nissan
Used Porsche
Used Saab
Used Scion
Used Subaru
Used Suzuki
Used Toyota
Used Volkswagon
Used Volvo
2010 Honda Civic
$15,770
2004 Jeep
$8,991
2012 Mustang
$22,990
1997 Honda Cr-V
$4,490
2010 Toyota Prius
$17,496
2010 BMW 328
$26,980




Automotive Forum Categories
Automotive Repair
Auto Body Repair and Refinishing
AC Auto Repair Help Forum
Automotive Wiring and Electrical

Auto Insurance and Car Financing
Automotive World
Brake Systems
Car Stereo Repair Advice
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair

Steering and Suspension
Tricks of the Trade
General Discussions
Car Shows and Events
The Bargin Bin
Motor Vehicle Inspection
Car Care Tips
Traffic Ticket Help
Car Racing

Gasoline, Motor Oils, Concept Cars
Remote Control Cars and Vehicles
Truck Repair
Truck Repair Advice


Truck Engine Repair
Truck Suspension Repair
Motorcycle Repair
Motorcycle and ATV Repairs

Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Seat Repair
Car Forum Posts - Sitemap


Search for (options) Privacy