Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

Doesn't Shift into first gear


First page Previous page 1 2 Next page Last page  View All Email This Post



mactube
User

Jan 13, 2020, 4:14 PM

Post #1 of 31 (1826 views)
Doesn't Shift into first gear Sign In

 My 2016 Hyndai Elantra ( Automatic Transmission) won't shift into 1. gear anymore unless I let the RPM run real high while I'm standing, it will eventually go in to 1st gear.

It started with taking about 4-5 seconds to Sh!t into first gear than longer and longer until it won't go in at all unless I keep messing with the shift stick ... shifting it back and forth into Park , Reverse , etc. and then hitting the gas when its in Drive to about 4k rpm (which feels like its in Neutral) and it will eventually go into gear.

Which lets me believe, that it might not be the actual gears in the transmission but more of a computer problem and the pressure will have to just build up and then it will shift.

I think it the problem that I had with the car idling up and down while I'm stopped at a red light with the A/C running has something to do with it.

Does somebody have an idea what it would be or what to check for?


gsferraro
Enthusiast

Jan 14, 2020, 4:03 PM

Post #2 of 31 (1771 views)
Re: Doesn't Shift into first gear Sign In

Hello,
Can you tell me your engine size? also, how is reverse? Gary


mactube
User

Jan 15, 2020, 2:08 AM

Post #3 of 31 (1750 views)
Re: Doesn't Shift into first gear Sign In

@gsferraro its a 1.8L 4 Cylinder. I first had some issues to get it into Reverse, but that problem is gone it now shifts right up into reverse.
... and now the Check Engine light came on and it reads :

P0722 Output Safe Speed Sensor Circuit No Signal
P0743 Torque Converter Clutch Solenoid Circuit Electrical


gsferraro
Enthusiast

Jan 15, 2020, 4:45 PM

Post #4 of 31 (1721 views)
Re: Doesn't Shift into first gear Sign In

ok, the Po743 code is an electrical code for the trans, this may put the car in failsafe mode which means instead of the car starting out in first it may start out in fourth gear, so does this seem taking off heavy from a start like it's in a higher gear? If you clear the codes do they come right back. Gary


mactube
User

Jan 15, 2020, 11:21 PM

Post #5 of 31 (1705 views)
Re: Doesn't Shift into first gear Sign In

@gsferraro

When it does go into gear after I ran up the rpms, it will go into 1st gear though.

But its good to know what its an electrical problem. It sounds more affordable then a mechanical problem inside the transmission. Even though the Valve/Solenoid / Torque Converter Clutch Module only comes in one piece for the Elantra and parts can't be bought separately.

I was actually at a transmission shop today and they looked up an output and input sensors which is one part, since the Error Codes came up for the sensors too. This part is only $150 at AutoZone and $80 used. But I looks like it will be installed inside the transmission housing on the 2016 model, vs. simply outside like on the previous Elantra models. If thats the case, the labor to replace it will be so high, that if that doesn't fix the problem, to replace it almost makes no sense instead to replace the whole transmission with a used transmission ( 1k) which comes with 30 Day warranty before I keep trying different parts.

I'm really kinda in limbo here..

The Shop erased the codes, the check engine light is off now, and problem is still the same.


gsferraro
Enthusiast

Jan 16, 2020, 5:38 PM

Post #6 of 31 (1673 views)
Re: Doesn't Shift into first gear Sign In

ok, go back to auto zone or the shop, lets see what code came back. The speed sensor code may be being produced because the trans is starting out in a higher gear, the computer is not seeing the ratio it needs to see so it blames the sensor, if it's still in failsafe, see if the P0743 code came back. Would you mind posting your VIN Number?


mactube
User

Jan 16, 2020, 10:41 PM

Post #7 of 31 (1659 views)
Re: Doesn't Shift into first gear Sign In

The Elantra is at the Hyndai Service Center update tomorrow.


gsferraro
Enthusiast

Jan 17, 2020, 4:47 PM

Post #8 of 31 (1641 views)
Re: Doesn't Shift into first gear Sign In

ok, sounds good. Gary


mactube
User

Jan 18, 2020, 12:38 PM

Post #9 of 31 (1620 views)
Re: Doesn't Shift into first gear Sign In

According to the Hyndai Service shop
Hyundai Service Diagnosis ($140): Your Transmission in broken !Frown
Me : Like I didn't know the Thats why I dropped off the car here.
After about 30 min of digging a little more specific but still a wage as it can be: The valve body is broken.
So no answer about what causes the transmission to not shift. From my understanding a used valve body is not to expensive and not hard to replace.


gsferraro
Enthusiast

Jan 18, 2020, 3:22 PM

Post #10 of 31 (1610 views)
Re: Doesn't Shift into first gear Sign In

From the code you have, a solenoid or internal harness is no good, the P0743 code is a code for the Lock-up solenoid or TCC solenoid. Gary
would you mind posting your vin number


(This post was edited by gsferraro on Jan 18, 2020, 3:24 PM)


mactube
User

Jan 19, 2020, 12:19 AM

Post #11 of 31 (1593 views)
Re: Doesn't Shift into first gear Sign In

I have a new code from the Service Center : P0106 Manifold Absolute Pressure/Baro Sensor
And still: P0722 Output Shaft Speed Sensor Circuit
As well as the Map Sensor
Vin is coming up..
Actually send it to your inbox.
Unless its not problem to post here!?


mactube
User

Jan 19, 2020, 12:26 AM

Post #12 of 31 (1586 views)
Re: Doesn't Shift into first gear Sign In

From my understanding, the solenoids at the 2016 Hyundai Elantras Valve body can't be replaced separately. Its comes in one piece.


mactube
User

Jan 19, 2020, 12:49 AM

Post #13 of 31 (1582 views)
Re: Doesn't Shift into first gear Sign In

Vin in link :


https://drive.google.com/file/d/1EWae3NtUmDVH--QHpq0oRnb-XAK49gDG/view?usp=sharing

(This post was edited by mactube on Jan 19, 2020, 1:00 AM)


gsferraro
Enthusiast

Jan 19, 2020, 7:06 AM

Post #14 of 31 (1567 views)
Re: Doesn't Shift into first gear Sign In

could not click on the link, do you still have the 743 code. Gary


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jan 19, 2020, 7:37 AM

Post #15 of 31 (1562 views)
Re: Doesn't Shift into first gear Sign In

This should click Gary...….
> https://drive.google.com/...q0oRnb-XAK49gDG/view <


Tom


gsferraro
Enthusiast

Jan 19, 2020, 10:24 AM

Post #16 of 31 (1556 views)
Re: Doesn't Shift into first gear Sign In

Ran the vin number found a TSB on the code, It says to replace the solenoid and the internal harness.
I think the TSB number is 19-AT-015H
I got this through shopkey pro


mactube
User

Jan 20, 2020, 7:19 PM

Post #17 of 31 (1533 views)
Re: Doesn't Shift into first gear Sign In

Yes still the same codes. Hey @TomGreenleaf is back in here
.. missed you .. thanks for the clickable Link ...( still have problems to insert photos and links in the forum with my browser.)

Nice @gsferraro thank you. So since the solenoids don't come separate anymore ( with this model) and I think the harness is inside the valve body. I should be able to replace the valve body which includes the 2 components with a working used valve body and I should be good !? What's your guys opinion, should I take the chance ? If any metal hardware by the gears or the the actual gears were broken ( which would require me to really get a new transmission) it would trigger an additional code correct ?


gsferraro
Enthusiast

Jan 21, 2020, 4:20 PM

Post #18 of 31 (1501 views)
Re: Doesn't Shift into first gear Sign In

Hello,
May or may not, what needs to be done first is get the trans out of failsafe mode to see how it works, these internal harness do fail and I think they are not that bad price from the dealer, you could ohm the solenoid, if that's ohm's ok just replace the harness assemblies. I will be out of town for a few days but will try to check the forum to answer any questions you may have. Gary


mactube
User

Jan 22, 2020, 4:42 PM

Post #19 of 31 (1469 views)
Re: Doesn't Shift into first gear Sign In

Ok great, thank you!
Yes, a visual of the location of the harness would be great to get an idea of the job. ... safe travels !


gsferraro
Enthusiast

Jan 27, 2020, 6:13 PM

Post #20 of 31 (1358 views)
Re: Doesn't Shift into first gear Sign In

Hello,
This transmission has no bottom pan, it has a side cover, the valvebody lives behind the cover, I do believe it has to be removed to access the harness, the harness is 2 piece assembly. Gary

I gave you the TSB number in an earlier post, did you try to google to see if it comes up, if it does there should be pictures


(This post was edited by gsferraro on Jan 27, 2020, 6:14 PM)


mactube
User

Feb 4, 2020, 3:45 PM

Post #21 of 31 (1238 views)
Re: Doesn't Shift into first gear Sign In

@gsferraro sorry for the delay! Yes, but I have not ben able to get a good description of the repair yet, to find out if I will be able to do it myself or if its worth taking the rest of replacing the parts separately based upon the error codes.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Feb 4, 2020, 4:10 PM

Post #22 of 31 (1232 views)
Re: Doesn't Shift into first gear Sign In

I made a PDF copy of the TSB and tried to attach it to a PM but the file is way too large.

PS, I just e-mailed it to you



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



(This post was edited by Hammer Time on Feb 4, 2020, 4:14 PM)


mactube
User

Feb 15, 2020, 9:16 PM

Post #23 of 31 (1077 views)
Re: Doesn't Shift into first gear Sign In

Thank you so much @Hammer Time that would have been the help that I needed ! But as @gsferraro mentioned this transmission has a side cover and you can not get to the valve body from the bottom by laying under the car, so there was no way for me to access the side cover.
I now eventually had to take the car to a transmission shop, that installed a used trani for 1k that I found. So unfortunately I wasn't able to use CarJunky for a DIY cheaper solution .. but thanks everybody anyway ! Shout out to @TomGreenleaf of cause as always !

... Trani doesn't shift real smooth when the car is warm. Do used transmutations have to be programmed or adjusted when they go into another car ?


gsferraro
Enthusiast

Feb 16, 2020, 12:15 PM

Post #24 of 31 (1060 views)
Re: Doesn't Shift into first gear Sign In

Hello,
You could try a relearn but make sure no codes are present in trans or engine, check engine light cannot be on. If it still works the same way, possible valvebody problem. Surprised the shop didn't offer to fix the electrical problem.


(This post was edited by gsferraro on Feb 16, 2020, 12:17 PM)


mactube
User

Feb 17, 2020, 2:07 PM

Post #25 of 31 (1033 views)
Re: Doesn't Shift into first gear Sign In

Will it relearn by itself ?

It actually shifts pretty bad now. The repair labor costs would have been the same maybe a little less than $650 and a new valve body would have been a couple of hundred less than the whole transmission but there could have Been internal gear/transmission problem. If that would have been the case .. Tha costs would have started all over again. So that was the suggestion of the shop. Which made sense at the time, but now the transmission shifts like its already broken. ... so on my way back to the shop...






First page Previous page 1 2 Next page Last page  View All Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap