Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









4L80E shifting problem


  Email This Post



ekeck
New User

Jul 8, 2005, 4:27 PM

Post #1 of 4 (9873 views)
Shortcut
4L80E shifting problem Sign In

I have a 1996 Chevy 3500 dullaly with the 4L80e transmision. The tranny will pull fine shift great most the time, but sometimes it will act as though the converter has just disengaged. The RPM will race up unchecked and the tranny will not hook back up until I completly let off the throttle. Any ideas? Please help!
Ed Keck


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jul 9, 2005, 2:37 AM

Post #2 of 4 (9849 views)
Shortcut
Re: 4L80E shifting problem [In reply to] Sign In

First - make sure it's full of fluid and if not find out why!

Next - check color of fluid on white paper. If you don't say "red" then it's probably toast!
_________________________________________
Long retired now


ekeck
New User

Jul 9, 2005, 6:39 AM

Post #3 of 4 (9847 views)
Shortcut
Re: 4L80E shifting problem [In reply to] Sign In

fluid is fine, good red color, level fine what now? The tranny does not slip pulling a load 1st through 3rd. I just don't understand!
Ed Keck


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jul 9, 2005, 8:29 AM

Post #4 of 4 (9839 views)
Shortcut
Re: 4L80E shifting problem [In reply to] Sign In

Both good signsSmile From here I would take the veh to a reputable trans shop for a test drive and their asessment with the veh in front of them and a quote on a fix. This should be free.

Never hurts to do a check for wiring and vacuum leaks yourself.
_________________________________________
Long retired now




4L80E shifting problem


  Email This Post
 
 






Latest Forum Post

If anyone wouldn't mind giving me some feedback, I would like to have some idea ...


2001 chevy tracker 2.0 engine with 4 cylinders 175k miles. (car has sat still fo...


98 dodge Durango 193,000 miles 5.9 engine once again I need help, been running 3...


Was having trouble starting 2007 Toyota Rav 4 and got it towed to shop. They sai...


I own a 2006 Subaru WRX, 2.5L turbo, hatchback model with no mechanical modifica...


Hello, I'm new here, have a problem with a 2000 Mazda 626 , LX V6. My father ow...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics