Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

'00 Frontier Trans rebuild didn't fix problem - slipping into neutral


  Email This Post



alohajim
New User

Nov 20, 2019, 3:54 PM

Post #1 of 2 (466 views)
'00 Frontier Trans rebuild didn't fix problem - slipping into neutral Sign In

I have a 2000 Frontier with 211000 miles. It was slipping out of gear and revving on the highway at several different speeds. Took it to a trans shop and they said it was pulling a 3rd gear code. Also determined that the trans probably needed a rebuild. Agreed (silly me) to the rebuild and it didn't fix the problem. Brought it back twice and the second time they replaced the valve body assembly. The code wasn't showing after the rebuild, so they didn't replace the computer module.

I am taking it back in today for the 4th time in as many weeks. Have heard that the throttle position sensor could be an issue, but don't want to keep throwing money at it. I'm already in for $3600.

Any ideas would be helpful.


(This post was edited by alohajim on Nov 20, 2019, 3:55 PM)


gsferraro
Enthusiast

Nov 20, 2019, 4:55 PM

Post #2 of 2 (459 views)
Re: '00 Frontier Trans rebuild didn't fix problem - slipping into neutral Sign In

Hello,
Does it keep getting the same problem with 3rd gear? How long is it good for after they fix it? Did they change the solenoids. When you bring it back does the fluid smell burnt?Gary00






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap