Main IndexAuto Repair Home Search Posts SEARCH
Who's Online WHO'S
Log in LOG

2002 chevy s10, a/c fans won't blow

  Email This Post

novice car girl
New User

Oct 10, 2007, 5:05 PM

Post #1 of 3 (3861 views)
2002 chevy s10, a/c fans won't blow Sign In

i just picked up a 2002 chevy s10 pick up from my grandfather. he told me that the a/c and heater were not working, and that the problem was probably as simple as a blown fuse. so i decided to check it out for myself......
here's the deal. the fans wont blow at all. i know the compressor is still working because it gets cold.
so, i checked out every fuse labeled hvac and none appeared to be broken. still i changed them, but had no luck. the fans still won't blow.

is there something i'm missing here? (that's rhetorical. i obviously am.)

any help would be greatly appreciated. please keep it simple, i'm just a beginner with this stuff Smile thanks!!!

Veteran / Moderator
way2old profile image

Oct 10, 2007, 5:26 PM

Post #2 of 3 (3859 views)
Re: 2002 chevy s10, a/c fans won't blow [In reply to] Sign In

Here is a diagram of the electrical circuit. Look on the left side of diagram. It has the main fuse, relay and blower motor. The fuse in in the underhood fuse box. Then the relay and blower motor. Check at the blower to see if there is current going to the motor. If there is current, the motor may be bad causing the problem. If there is no current at the blower, check the resistor. If there is current there, check the relay and if there id current there, go to the fuse under the hood. Hope it is not too confusing.

Being way2old is why I need help from younger minds

(This post was edited by way2old on Oct 10, 2007, 5:28 PM)

novice car girl
New User

Oct 10, 2007, 8:25 PM

Post #3 of 3 (3855 views)
Re: 2002 chevy s10, a/c fans won't blow [In reply to] Sign In

thanks for your help!!!

2002 chevy s10, a/c fans won't blow

  Email This Post

Latest Forum Post

I have a 2003 Jeep Liberty a when I applying the brakes with a the engine revvin...

Hi all. First time poster, likely not last time though :), so bear with me... ...

Newbie to forum and need some help. I have a 2005 Chevy 2500 HD diesel and the p...

1995 Chevrolet Lumina LS, 3.1, 4t60e trans, odometer read 211,000+ new motor 125...

I start my car in the morning and it immediately dies. I start it again and befo...

I have a 2002 buick lesabre with a 3.8 auto trans that squeals when turning righ...

Feed Button

Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap

Search for (options) Privacy

web statistics