Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









03 corolla A/C problem


  Email This Post



gregralston
New User

Jul 13, 2009, 11:12 AM

Post #1 of 3 (809 views)
Shortcut
03 corolla A/C problem Sign In

2003 Toyota Corolla

I just bought a used certified 2003 Toyota corolla 3 days ago. Everything worked when I got it. Today when I went to adjust the temperature control down it would not adjust. It acts like a spring return - can't move the dial to blue or red areas it only moves in the middle white area. The fan also seems to not blow as I turn it up. Crazy

Okay an update - I got in the car in the afternoon and everything was back to normal - like maybe the compressor had frooze up causing the problem and once it thawed out it went back to working? It quit working halfway through a long drive (5 hrs). Anyone seen anything like this? I'm expecting it to happen again. The air blows cold so it doesn't appear to be low on refridgerent.


(This post was edited by gregralston on Jul 13, 2009, 3:36 PM)


Loren Champlain Sr
Veteran / Moderator
Loren Champlain Sr profile image

Jul 13, 2009, 1:48 PM

Post #2 of 3 (805 views)
Shortcut
Re: 03 corolla A/C problem [In reply to] Sign In

greg; I'd be surprised if the control uses a cable, but that's what it sounds like....a binding cable. If this was 'Certified', you should be able to take it back and have them repair it for you. JMO.
Loren
SW Washington


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jul 15, 2009, 4:27 AM

Post #3 of 3 (783 views)
Shortcut
Re: 03 corolla A/C problem [In reply to] Sign In

To add: Control head/dials/knobs not turning and any icing issue (unknown) are unrelated IMO,

T
_________________________________________
Long retired now




Advertising


  Email This Post
 
 






Latest Forum Post

I recently blew an engine-'01 CHEV SILVERADO 5.3L-& had an '02 5.3L transpla...


hi, my engine still runs after i turn the key off then dies after few seconds, w...


I have a weird situation in that my run lights won't work on my utility trailer....


My 1995 Nissan Quest starts just fine. When I depress the brake pedal and move t...


I have a 1992 ford ranger 3.0l v6 5 speed. today i ran out of gas and when i got...


Hi there! I had a problem with my clutch, removed the transmission and need to ...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy