Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

starts then dies code p1351


  Email This Post



celticwild
Novice

Dec 4, 2014, 8:16 PM

Post #1 of 11 (1392 views)
post icon starts then dies code p1351 Sign In

I have a 97 gmc yukon. With a 5.7l and about 160,000 miles.

I was geting a crank but no start. Changed the plugs, the plug wires, disturbeter, rotor, coil, ignition control module, crankshaft position sensor, and fuel filter. Now it's starts then dies, with a code of p1351. Have 60 to 65psi of fuel. Any ideas or help would be greatly appreciated


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Dec 4, 2014, 9:56 PM

Post #2 of 11 (1376 views)
Re: starts then dies code p1351 Sign In

That code may be throwing you off right now. OK - first all crank no start and you tossed parts at it and did check fuel pressure which is correct enough for now.


If you messed with distributor you will need to set timing with equipment you probably don't have. Can't mess with distributor like this one without losing timing which is not physically adjustable like an older one.


It runs at all it's probably that now.


Easy on tossing parts like that for a no start as it can/does confuse what the original real problem was when it wouldn't start at all,


T



celticwild
Novice

Dec 4, 2014, 10:19 PM

Post #3 of 11 (1369 views)
Re: starts then dies code p1351 Sign In

Thank u tom. I put rotor back on the way I took it off and cap can only go on one way. I'm wondering if it's a security-related issue


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Dec 5, 2014, 3:09 AM

Post #4 of 11 (1363 views)
Re: starts then dies code p1351 Sign In

The P1351 means you have an ignition control problem. Go back and check all your work. Make sure all the plugs are fully seated. Also make sure none of the pins got bent over in the process of plugging them in. If any were hard to get latched. pull the plug out and look at the pins inside.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



celticwild
Novice

Dec 5, 2014, 5:03 AM

Post #5 of 11 (1350 views)
Re: starts then dies code p1351 Sign In

Thank u hammer time. I'll go check all pins and ports. With the 5.7v to the icm cousing the p1351 why am I geting good spark?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Dec 5, 2014, 6:39 AM

Post #6 of 11 (1345 views)
Re: starts then dies code p1351 Sign In

You never said you had good spark. Is there any security indicator on or flashing when you try to start it?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



celticwild
Novice

Dec 5, 2014, 10:08 AM

Post #7 of 11 (1335 views)
Re: starts then dies code p1351 Sign In

Oh sry i though I put that in there. No but I think my security bulb is out. When I turn the key on it doesn't light up and I know that I have one. But I can't find anything on if my truck has one besides the one in the stock radio


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Dec 5, 2014, 10:55 AM

Post #8 of 11 (1333 views)
Re: starts then dies code p1351 Sign In

That is likely it. They did put them in the radio on some of them.

I would erase that code and see if it comes back again.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



(This post was edited by Hammer Time on Dec 5, 2014, 10:56 AM)


celticwild
Novice

Dec 5, 2014, 11:24 AM

Post #9 of 11 (1329 views)
Re: starts then dies code p1351 Sign In

That code does come back. The truck will start up and then die. Sprayed starter fluid in the carb after and it acks like there is no spark. I tryed that leave on for ten min then try to start it but I git nothing and then I read some where that I might have to do it three times inarow. Still nothing new. Is there any other way to reset a security-related issue?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Dec 5, 2014, 1:29 PM

Post #10 of 11 (1322 views)
Re: starts then dies code p1351 Sign In

Unless you have a security light flashing I wouldn't blame the security system. That wouldn't effect spark anyway. You have something wrong in the primary ignition system.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Dec 5, 2014, 1:57 PM

Post #11 of 11 (1313 views)
Re: starts then dies code p1351 Sign In

Confused at what's noticed? First this had all crank no start and all those parts replaced list in top post. Then it started and wouldn't stay running. You've said it had good spark and now back to "like it doesn't have spark" and back to sq. one with it all cranking and doesn't react to a prime - right?


How are you testing for spark at all? One of these would be useful about now........

A tester in line to show how far it can jump or at all if the pic shows.


Have you re-checked what you did already for anything plain broken?


BTW - it doesn't have a carb and know what you mean I hope but that's a throttle body.


Plugs too right? What kind? Possible with all the messing with it and cranking they are so flooded you should check. Use on exact proper replacements not even other brands for this. Lists only an "R" code Vortec for a 5.7 and says so under hood. No other 5.7 version shown?


T


T







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap