Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

cruise control not working on my 1999 ford crown vic


  Email This Post



grande47
Novice

Jul 24, 2015, 8:57 PM

Post #1 of 2 (1990 views)
cruise control not working on my 1999 ford crown vic Sign In

I did some research and I learned that some of these cars have a secondary disconnect under the hood, somehow on the brake system. I looked and cannot find one on my 1999 crown vic lx. the cruise light won't come on and the fuse is good so I am at a loss, please help


Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Jul 24, 2015, 9:07 PM

Post #2 of 2 (1986 views)
Re: cruise control not working on my 1999 ford crown vic Sign In

Air bag light on?
Does the horn work?
Brake lamps working correctly?

There are three switches that will deactivate the cruise control system. One is the on and off switch on the steering wheel. Two is the brake pedal position switch at the brake pedal which has light green and light green/red wires. Three is the speed control deactivation switch also at the brake pedal.

Make sure the brake pedal position switch and deactivator switch are working and adjusted properly. If all that is good, the horn works, and you don't have air bag lamp on, you'll have to break out the volt meter and make some electrical checks.

cruise control deactivator switch:


brake pedal position switch:






Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.

(This post was edited by Discretesignals on Jul 24, 2015, 9:23 PM)






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap