Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




Unusally coolant leak 2001 frontier


  Email This Post



AJ Frontier
New User

Sep 18, 2009, 2:26 PM

Post #1 of 2 (1184 views)
Shortcut
Unusally coolant leak 2001 frontier Sign In

I have a 2001 Nissan Frontier 4x4 3.3 V6 108000mi and it has a very unusually coolant leak. It only leaks after the engine has shut off - but not every time. It appears that the coolant is coming from the weep hole at the water pump (not 100% on this). I realize that if coolant is coming from the weep hole then a seal has failed, but what I don't understand is why it isn't consistent?

A few weeks back I had a new radiator put in becuase I was having over heating issues. Once the new radiator was in the over heating disappeared. Then two weeks later I suddenly have a huge coolant leak. Would there be any connection here?

I also replaced the radiator cap (the old one was faulty) in hopes that would fix the problem, but not sure if it has yet. As of this morning I have had no leaking.

The Water Pump was replaced at 90,000 miles when I had the timing belt replaced so it seems like a failed seal is unlikely unless the radiator replacement would somehow cause a seal to fail.

Anyone have any thoughts on this? I really don't want to replace a water pump and if anyone knows of any other things that would cause coolant to leak only after the engine is shut off I would greatly appreciate it.

Thanks


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Sep 18, 2009, 6:31 PM

Post #2 of 2 (1166 views)
Shortcut
Re: Unusally coolant leak 2001 frontier [In reply to] Sign In

A seal on anything with a shaft like a water pump is a strain on them. WPs need seal for vacuum and the pressures of the cap which dictates.

If you see so much as a smidgen of coolant or traces from a vent hole in a water pump it's no good and needs to go - again which stinks but it really won't heal,

T
_________________________________________
Long retired now




Advertising


  Email This Post
 
 






Latest Forum Post

 HotOil warning, from cold start, and won't start, Jeep JK wrangler 2010 un...


1990 chevrolet c1500 4.6 tbi 110k recently replaced motor w/ a 93 4.6 had a fe...


I own a TOYOTA CAMRY LE , the rear driver side passenger side door received a ve...


Hi all, I wanted to check with you how much labor wise could it cost me to repl...


Mechanic changed serpentine belt on 09 Chevy Cobalt, said there were cracks in i...


1992 ford explorer,xlt,4.0,about two weeks ago alternator was over charging so r...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy