Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Town and Country Rough Running, P2308 code, Coil? Wires? Plugs?


  Email This Post



djs789
New User

Jul 20, 2010, 11:17 AM

Post #1 of 5 (1262 views)
Shortcut
Town and Country Rough Running, P2308 code, Coil? Wires? Plugs? Sign In

I have a 2006 Chrysler Town and Country 3.3l. The check engine light is on and I am getting P2308 error code. The Parts store print out says this is an erratic signal from the ignition coil secondary circuit.
The probable causes are:
1.Faulty spark plug or coil boot or 2.Failed ignition coil.
The van is running rough, Has a rough idle, Hesitation, Sputtering, Excessive engine vibration.
I replaced the spark plug wires a month ago. I replaced the coil and the spark plugs today.
The van is still running rough any suggestions?


Sidom
Veteran / Moderator
Sidom profile image

Jul 20, 2010, 11:15 PM

Post #2 of 5 (1250 views)
Shortcut
Re: Town and Country Rough Running, P2308 code, Coil? Wires? Plugs? [In reply to] Sign In

There are a few more other things that can cause this problem then what you have listed. That code is for the coil circuit for #3 cyl. You should've had a P0303 as well...strange...

Since you've changed the plugs with no change, what you can do is clear the codes and switch the #3 wire to a different cyl. If you get a code for the cyl you moved the wire to then you have a bad wire...

After that it gets a lot more indepth and you will need a scanner and some other equipment to check out the circuit out to see where the problem lies..........






__________________________________________________________________________________________



djs789
New User

Jul 21, 2010, 1:18 PM

Post #3 of 5 (1237 views)
Shortcut
Re: Town and Country Rough Running, P2308 code, Coil? Wires? Plugs? [In reply to] Sign In

Update:
I checked for arcing at night. No arcing. I rechecked and set gaps on the new plugs I put in.

The p2308 code is an error in the ignition coil #3. Coil #3 fires cylinders 2 and 5.
Erased the code. Then I flopped sprk plug wires from another cylinder for the number 2 wire.
I get the same p2308 code come. I did the same with the 5 cylinder wire with the same results.
So I am pretty sure its not the wires, plugs, and coil (which is new).

I checked with a TEST LIGHT the control wires for all three of the coils with the engine running.
Pin #1 (brown/orange wire) control wire for coil #3 LIGHT GLOWS CONSTANT. I think this is wrong.
Pin #4 (dark blue/tan wire) control wire for coil #2 LIGHT FLASHES - I think this is normal.
Pin #3 (dark blue/dark green wire) control wire for coil #1 LIGHT FLASHES - I think this is normal.

Since the control wire glows the wire must not be bad or grounded. I think the pcm must be bad.
Probably a good bet the computer is bad and should be replaced?

I don't know. Is there anything else I should check? The pcm is expensive. What do you think?

Any suggestions on replaing the computer if you think I should?


Hemi Guy
User

Jul 21, 2010, 5:25 PM

Post #4 of 5 (1228 views)
Shortcut
Re: Town and Country Rough Running, P2308 code, Coil? Wires? Plugs? [In reply to] Sign In

First make sure the ignition wire boots are dry and free of al moisture. If that doesn’t do it
Chrysler has a pcm update (re-flash) for p2308. (TSB number 18-008-05).



djs789
New User

Jul 28, 2010, 10:54 AM

Post #5 of 5 (1201 views)
Shortcut
Re: Town and Country Rough Running, P2308 code, Coil? Wires? Plugs? [In reply to] Sign In

Update:
I traced a bad coil driver signal going into the coil all the way back to back to the pcm for coil#3. I determined the pcm had a bad coil driver for the #3 coil. I ordered the remanned computer from Auto Computer Exchange in FL.
I installed the new computer. It seems to work. The computer has a lifetime warranty so I think I am golden. Thanks for your help.




Town and Country Rough Running, P2308 code, Coil? Wires? Plugs?


  Email This Post
 
 






Latest Forum Post

I hear a repetitive growlong from the rear of my car (1999/200 Hyundai Lantra 13...


I have a 2004 Chevy Silverado.when I press on the gas the the throttle/air intak...


I had the belts changed on my 2004 Infiniti G35 6-Speed Sedan according to the m...


2000 Ford Focus 2.0 208k Miles Hey folks. New guy here having an issue with my ...


1991 GMC K1500 5.7. Engine runs fine til it warms up then when you apply brakes...


I've got a 1997 Infiniti i30 V6 with ~188k miles. lately it's been starting roug...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics