Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




Search Auto Parts

No acceleration when pushing the gas pedal


  Email This Post



Payam30
New User

Mar 30, 2017, 9:21 AM

Post #1 of 2 (168 views)
No acceleration when pushing the gas pedal Sign In

Hi,
I have a :
Suzuki Liana 1,6 5D 2003 with 141 000 km Manuel transmission with 6 gear. 5 forward 1 reverse. It began a morning when I was on high way. I pushed the gas pedal and what ever I did the speed wouldn't go upper than 70 km/h (43 mil/h). I drove a while and saddenly speed went up to 100 km/h (62 mil/h) and the car went very smoothly.

It happened again two days after and this time the engin light went on. I drove to mechanics and he said the oxegyn-sensor(or something) should be changed. He changed it with a used one. it did work for one week and now it happened again.

So I opened the airfilter. Cleaned it though i wasn't so dirty. I had changed the engine oil at 140000.

I noticed that when I open the tank door and it sounds like it comes out or goes in air. it sounds like psssssssss. and then the car is allright. This happens everytime I open the tank to fill feul.

The oil filter replaced when changing engine oil.


(This post was edited by Payam30 on Mar 30, 2017, 9:28 AM)


Isaac22
User

Apr 9, 2017, 8:02 AM

Post #2 of 2 (124 views)
Re: No acceleration when pushing the gas pedal Sign In

It sounds like you might have a probolem with your Evap system. It could be a plugged line or a plugged charcoal evap canister. And also does the air when it hisses smell the gas if so it is proboboly gas fumes. Also when you fill up and use the auto stop function on the pump does it just shut off right away.






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap

shopify
site analytics