Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

Nissan Rogue 2010 - Blower not working


  Email This Post



SamLach
New User

Oct 18, 2017, 4:38 PM

Post #1 of 2 (241 views)
Nissan Rogue 2010 - Blower not working Sign In

Hi,
On my way to work this morning I realised that the blower in my car (Nissan Rogue 2010) wasn't working.
No air was pushed in the car, no matter the speed the knob was set to. The light on that knob, for recirculation, also won't turn on.
I therefore assumed it was a fuse problem. I looked at the 2 "Blower" fuses, and some others that I thought could be relevent, but they all looked fine...

Do you have any suggestion as to what the problem might be and how to troubleshoot it?

Thank you for your help.

Here is a picture of the controls, all apparently working apart from the left knob.


EDIT : Upon further verification. The light on the know does work afterall.
So I guess the problem lies with the blower itself.
Do you know how I could confirm that?
Thanks again!


(This post was edited by SamLach on Oct 18, 2017, 4:57 PM)


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Oct 18, 2017, 4:57 PM

Post #2 of 2 (231 views)
Re: Nissan Rogue 2010 - Blower not working Sign In

You need to test for power and ground arriving at the motor when turned on. Which one is missing will determine the next step.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap