Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN







Search Auto Parts

My car stalls immediately after start!!!!!!!!


  Email This Post



Guest
Anonymous Poster

Aug 18, 2006, 2:21 PM

Post #1 of 13 (28924 views)
My car stalls immediately after start!!!!!!!! Sign In

I have a Nissan X-trail 2003 (with a qr25de gasoline engine same as altima 2.5). Few weeks before, i had an ignition problem. I replaced the crankshaft position sensor and fixed it. The car started to run smoothly. But 4 days later, a new problem appeared. The engine stops immediately everytime I start it.

can somebody help me with this?

thanks


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Aug 18, 2006, 9:32 PM

Post #2 of 13 (28909 views)
Re: My car stalls immediately after start!!!!!!!! Sign In

Is it fuel or spark if you can find that out it would help, T



haze386
User

Aug 19, 2006, 3:33 PM

Post #3 of 13 (28904 views)
Re: My car stalls immediately after start!!!!!!!! Sign In

today I sprayed the intake with carb cleaner while starting and it somehow mainated the rev of the engine. So i think the problem is fuel. But I don't know which part is causing it.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Aug 19, 2006, 3:56 PM

Post #4 of 13 (28902 views)
Re: My car stalls immediately after start!!!!!!!! Sign In

It's fuel, fuel pressure? Bear with me I'm having computer PMS. This note sent before it does it's thing againMad T



haze386
User

Aug 19, 2006, 8:15 PM

Post #5 of 13 (28896 views)
Re: My car stalls immediately after start!!!!!!!! Sign In

i invited a mechanic today, he did few tests and said that it is most likely a fuel pump problem. he towed the car to his repair shop. I will let u know the developments. Thanks


haze386
User

Aug 19, 2006, 8:17 PM

Post #6 of 13 (28895 views)
Re: My car stalls immediately after start!!!!!!!! Sign In

how much does a fuel pump costs?


haze386
User

Aug 24, 2006, 8:38 PM

Post #7 of 13 (28882 views)
Re: My car stalls immediately after start!!!!!!!! Sign In

alright.... the mechanic fixed the stalling problem. but the engine won't go above 2,500 revs when steped on gas pedal. he is still reparing it. do u know what is wrong with it?


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Aug 24, 2006, 9:13 PM

Post #8 of 13 (28880 views)
Re: My car stalls immediately after start!!!!!!!! Sign In

From here I would do a vacuum test. MAP or the actual manifold vacuum should be the same at ide as at 2000 rpm or a restriction in exhaust is indicated which could cause that and so could other things.

That would be an easy test to at least rule that out, T



haze386
User

Aug 25, 2006, 1:51 AM

Post #9 of 13 (28878 views)
Re: My car stalls immediately after start!!!!!!!! Sign In

thanks for replying again tom. here is a more detailed description:

the mech. told me that he took out the intake valve (it was very dirty) and cleaned it and put it back on. he said that because of all the dirty deposits in the valve, it activated a error code to the computer. After the cleaning, the "immediate stall after start problem" was fixed.

the car is still with the mech. Now, no mater how hard i step down gas, the revs won't go up 2500rpm. and when i let my foot off the gas, the revs lower to about 300rpm and at that instant the will car start shaking for 2 seconds as if it would go stall, but keeps running and the revs go normal (about 800rpm all by itself).

the car has a normal idle, but about every 30 second the revs will lower down by itself to 300rpm and then back to normal (800rpm).


and also now the engine check light is on.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Aug 25, 2006, 4:28 AM

Post #10 of 13 (28876 views)
Re: My car stalls immediately after start!!!!!!!! Sign In

Hmmm! ONE dirty intake valve?? That's not a good sign on a model year 2003!

The big question is why and why just one??

The idle speed is controlled by an ECM and will do its best sensing of many things to keep it right.

The days of cleaning up a valve are gone. I'm showing my age but the old flat head engines this was a routine thing done with a paste and a suckshun cup that you could spin in your hands. Long ago and far away.

Got to find out why one cylinder is a problem, T



haze386
User

Aug 25, 2006, 11:51 AM

Post #11 of 13 (28872 views)
Re: My car stalls immediately after start!!!!!!!! Sign In

well... the mech just told me that the problem is mass sensor.... i have to change it... he said that a new one will cost me around $500. he also said that the spark plugs are full of carbon deposits. (any ideas why?). why did the mass sensor broke down? does it have to do with me changing the crank position sensor last week?


(This post was edited by haze386 on Aug 25, 2006, 11:54 AM)


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Aug 25, 2006, 3:18 PM

Post #12 of 13 (28866 views)
Re: My car stalls immediately after start!!!!!!!! Sign In

The mass air flow device is there measureing the speed and or volume of air going into your engine. From there it will tell the computer and make the adjustments to make the car run well all the time.

I believe it's a filiment like in a light bulb that senses this and converts the info for the car to make the adjustments.

I would call your local parts store and see how much a new one costs. Have your VIN ready. Call it a "mass air flow sensor" and see what you get for a price. The few I've known of were not labor intensive so it comes down to how much for this part.

Are they sure this is it? A code should come up for this item. No games and it may be covered by warranty. It should not have been damaged by the other work mentioned.

Make sure it's plugged in well as that has been a problem for me with a different car and the plug and holding device was a bit messed up and the car ran like junk until it was right.

Good luck and let us know how it works out, T



haze386
User

Aug 25, 2006, 6:00 PM

Post #13 of 13 (28865 views)
Re: My car stalls immediately after start!!!!!!!! Sign In

the mech replaced my sensor with a one from another car (same) and the engine began to work well. i already bought the sensor... for $134 (just sensor). I'll replace it tomorrow and let u know what happens.






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap

shopify
site analytics