Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

My Legacy died


  Email This Post



greasy one
User

Feb 7, 2017, 6:27 PM

Post #1 of 13 (432 views)
My Legacy died Sign In

   I plan to fix it thou maybe with some tips. Please forgive me for only coming around when I am stuck. SmileSo my 1995 Sub. acted a little funny after 11 years of flawless running; I noticed and drove off. After a half mile or so, she stalled for the first time ever. Now I really noticed and called for a wrecker. The car will start and sound fine, for a few seconds, and then stall. I see the fuel pump is in the hatch and I hope to change it tomorrow when it is 60 out and finish before Thursday when is blizzard out. I figure the pump has 187,000 miles on it and, most likely, just changing it will do it. Does this sound likely to you fellas?


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Feb 7, 2017, 8:49 PM

Post #2 of 13 (424 views)
Re: My Legacy died Sign In

Find out what went out, spark or fuel. Simply replacing a fuel pump is NOT in order IMO just because it's old or has 180+K on it, new one might not be as good?
Check fuel pressure and that it hold WHILE it's not running then check for spark and see what's missing. Can be totally other than that also just a good beginning with those two items,


T



greasy one
User

Feb 7, 2017, 9:37 PM

Post #3 of 13 (419 views)
Re: My Legacy died Sign In

 That makes sense. I am in a hurry due to storm but will investigate, at least a little. I think the spark is there thou because it will run fine for a few seconds. I did unhook the battery which finally ended my C.E.L. which has been on for 11/2 yrs !. Maybe it was trying to tell me about a low pressure with the fuel.IDK but the car ran well.


greasy one
User

Feb 8, 2017, 10:13 AM

Post #4 of 13 (389 views)
Re: My Legacy died Sign In

  Well my battery is charging and, when on, 70amps, I turn the key on and hear a humming from the pump which stops in 3 secs as well as, clicking, shut down, sort of noise from under the dash or maybe hood.


Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Feb 8, 2017, 11:18 AM

Post #5 of 13 (382 views)
Re: My Legacy died Sign In

You should charge the battery off the vehicle and then have it tested to be sure it is good.





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Feb 8, 2017, 11:37 AM

Post #6 of 13 (375 views)
Re: My Legacy died Sign In

Just a note: 70 AMPs from a charger? I'd seriously NOT use that setting and lower it to no more than say 15 and wait a couple hours if a normal just a bit low on a known good battery. Don't take one down too far they can croak from that and if cold if stone dead freeze and crack open.


Other: Hope you did run this with a battery cable off - that's a big no - no.


Hearing fuel pump is good but inconclusive. It would cycle off but at what pressure? Can't guess at spark you watch it good or not,


T



greasy one
User

Feb 8, 2017, 12:27 PM

Post #7 of 13 (371 views)
Re: My Legacy died Sign In

  When my car first died, I removed the battery cable which stopped and reset my Check Engine light and I saw a AT heat warning light come on. I felt the AT oil which was lukewarm. i never noticed this before but have ruled out fuel pump and I doubt a FP relay would work and then not work a few seconds later and repeat itself a 1000 times just the same way. The pump is feeding gas a plenty. I think this AT overheat sensor is bad or maybe something there is overheating. I am off to find its location.


greasy one
User

Feb 9, 2017, 6:47 AM

Post #8 of 13 (343 views)
Re: My Legacy died Sign In

Well no one is listing a AT oil temp sensor and can't find it. Something keeps shutting the car down.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Feb 9, 2017, 11:37 AM

Post #9 of 13 (335 views)
Re: My Legacy died Sign In

Don't tell us the dealer isn't listing it.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



greasy one
User

Feb 9, 2017, 3:14 PM

Post #10 of 13 (329 views)
Re: My Legacy died Sign In

 No time to check dealer but MAF sensor or connection seems to be common with same symptoms, also a large breather tube tube thingy that has no clamp but works its self loose under gravity. Th


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Feb 9, 2017, 3:42 PM

Post #11 of 13 (325 views)
Re: My Legacy died Sign In

If you don't have time to check the dealer for your parts, why are you bothering us with it?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



greasy one
User

Feb 9, 2017, 3:55 PM

Post #12 of 13 (321 views)
Re: My Legacy died Sign In

 Sorry next time I will delay the blizzard


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Feb 9, 2017, 3:59 PM

Post #13 of 13 (317 views)
Re: My Legacy died Sign In


Quote
Well no one is listing a AT oil temp sensor and can't find it. Something keeps shutting the car down.


Don't give me that crap. You post this response saying you can't find the part and when we tell you where you should have been looking, you tell us you don't have time and wander off into another direction.

We don't have times for the games and it doesn't even snow here.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap

shopify
site analytics