Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Fuel pump problem 99 Chevy Tahoe 5.7


  Email This Post



Altrescue
New User

Sep 3, 2011, 4:12 PM

Post #1 of 4 (2277 views)
Shortcut
Fuel pump problem 99 Chevy Tahoe 5.7 Sign In

I had to replace the heads on my 5.7 99 Tahoe and after putting the engine back together the fuel pump will not turn on. The fuel pump worked fine before the repair and if I jump the relay the fuel pump will turn on. The fuel pressure is good with it turns on, I have checked all the ground wires and they all seem to be hooked up. I cant figure it out, any help?


Altrescue
New User

Sep 3, 2011, 4:33 PM

Post #2 of 4 (2261 views)
Shortcut
Re: Fuel pump problem 99 Chevy Tahoe 5.7 [In reply to] Sign In

I forgot to mention that I replaced the relay with a new one and it still wont start


Discretesignals
Veteran / Moderator
Discretesignals profile image

Sep 3, 2011, 5:13 PM

Post #3 of 4 (2254 views)
Shortcut
Re: Fuel pump problem 99 Chevy Tahoe 5.7 [In reply to] Sign In

If you bypass the fuel pump relay and have the pump running, will the engine start?





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 3, 2011, 5:19 PM

Post #4 of 4 (2251 views)
Shortcut
Re: Fuel pump problem 99 Chevy Tahoe 5.7 [In reply to] Sign In

The PCM supplies trigger power to the relay on the Dk green with white wire. Check to see if you are getting that during the first 2 seconds of "key on" and once it starts cranking.
You should also check for spark when cranking




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.





Advertising


  Email This Post
 
 






Latest Forum Post

Hi,here's the info,hope a few members can help me please Car 1998 Olds int...


hey there folks. So i just bought my first car for $600. it was saftied and came...


My question is regarding a problem with an 03 Infiniti G35 with 5 speed automati...


 HotOil warning, from cold start, and won't start, Jeep JK wrangler 2010 un...


 Had starter, alt, battery checked. Car starts great but will go completely...


 will not start unless bumping starter, will not crank in starting position...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy