Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Fuel and filter change now car won't start


  Email This Post



Guest
Anonymous Poster
wdr12@earthlink.net

Apr 3, 2008, 2:06 AM

Post #1 of 4 (1372 views)
Shortcut
Fuel and filter change now car won't start Sign In

I changed my fuel pump and filter today and now my 2000 caravan wont start. Was running before i changed it. The pump is working and there is fuel pumpimg. I push the check valve in the fuel line and it is coming threw. What else might be the problem? I am at wits end here please help.


dmac0923
Enthusiast

Apr 4, 2008, 9:42 AM

Post #2 of 4 (1358 views)
Shortcut
Re: Fuel and filter change now car won't start [In reply to] Sign In

did you trip the inertia switch to bleed off the system pressure before the service???? make sure you reset that.

other then that it seems like you have air in the system and will just take alot of cranking and starts/stalls to get the air out.

the filter was installed in the correct flow direction right? just checking
__________________________________________________

2002 Ford Ranger
2004 Toyota Corolla
2011 Mercedes C300
1969 Ford Mustang Mach 1
1968 Ford Mustang 302 Coupe


Charlesmac
User

Apr 4, 2008, 8:15 PM

Post #3 of 4 (1349 views)
Shortcut
Re: Fuel and filter change now car won't start [In reply to] Sign In

Question., more specifics, if fuel pump was working, why did you chang it? Have you check the actual PSI pressure on the new fuel pump.


tcwagner
User

May 5, 2008, 1:34 AM

Post #4 of 4 (1298 views)
Shortcut
Re: Fuel and filter change now car won't start [In reply to] Sign In

Did you ever get it fixed?
Curious, Terry




Advertising


  Email This Post
 
 






Latest Forum Post

Year of vehicle 2004 Make of vehicle Nissan Model of vehicle Sentra Engine ...


Hey! I recently got my beloved VW Mk3 Golf 1.4L 1996 (N) MOT'd, I was considerin...


Hey I recently got my beloved VW Mk3 Golf 1.4 1996 MOT'd, I was considering scra...


1990 chevrolet c1500 4.3 tbi 110k recently replaced motor w/ a 93 4.6 had a fe...


 HotOil warning, from cold start, and won't start, Jeep JK wrangler 2010 un...


I own a TOYOTA CAMRY LE , the rear driver side passenger side door received a ve...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy