Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

Front Strut Question - Just had new installed


  Email This Post



bls8195
New User

Apr 12, 2016, 12:48 PM

Post #1 of 12 (854 views)
Front Strut Question - Just had new installed Sign In

I had new struts installed, I was told by my mechanic that the passenger side bolt is higher than the driver side, and I have pictures showing both sides, he just wants to make me aware of this, I called manufacturer and they said its normal as they are made for 4 different model SUV, they will issue a refund but I have to get them off again and everything is this truly normal, it doesn't move and its not hitting anything. This is on a 2008 Suzuki XL7 AWD


(This post was edited by bls8195 on Apr 12, 2016, 12:49 PM)


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Apr 12, 2016, 12:53 PM

Post #2 of 12 (850 views)
Re: Front Strut Question - Just had new installed Sign In

Don't understand what you mean. Maybe the pictures will help.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



bls8195
New User

Apr 12, 2016, 1:04 PM

Post #3 of 12 (845 views)
Re: Front Strut Question - Just had new installed Sign In

Basically under the hood on each side where you can see the top of the strut or is comes up to one is flush and the other has the bolt that is longer, the manufacture says this is normal as these are built for 4 different models. I just want to make sure.

http://www.suzuki-forums.com/attachments/2g-2007-xl7/64554d1460425605-front-struts-question-if-fine-not-image1460429197.374561.jpg

http://www.suzuki-forums.com/attachments/2g-2007-xl7/64562d1460425630-front-struts-question-if-fine-not-image1460429223.921309.jpg


(This post was edited by bls8195 on Apr 12, 2016, 1:09 PM)


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Apr 12, 2016, 1:28 PM

Post #4 of 12 (840 views)
Re: Front Strut Question - Just had new installed Sign In

I see that and don't like it but not sure either? Did this car get aligned and sit level with these? 1st pic look right, 2nd not so right and personally even if perfectly safe don't like it and would ask for a matched pair,


T



Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Apr 12, 2016, 1:29 PM

Post #5 of 12 (836 views)
Re: Front Strut Question - Just had new installed Sign In

How many did you change? Both of them?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



bls8195
New User

Apr 12, 2016, 1:31 PM

Post #6 of 12 (835 views)
Re: Front Strut Question - Just had new installed Sign In

Car has not been aligned yet, still needs to go in for that I just got this done 2 days ago. Driving and riding doesn't seem to be an issue, they won't send me another set, because they said that's how they are made, so basically I would have to get them taken out and returned for a refund which they will do, but I would also have to buy another set from somewhere so its a crapshoot, and more money now of course if its not right I get that and would have to do it, but if there is really nothing wrong then.


bls8195
New User

Apr 12, 2016, 1:33 PM

Post #7 of 12 (834 views)
Re: Front Strut Question - Just had new installed Sign In

Both were changed at the same time by a shop. They came from the company ready to install already put together the whole assembly for more of a quick install type of deal.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Apr 12, 2016, 1:40 PM

Post #8 of 12 (829 views)
Re: Front Strut Question - Just had new installed Sign In

That's nonsense. They are not different from left to right. He either used 2 different brands or they are installed wrong, possibly with parts missing.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Apr 12, 2016, 1:43 PM

Post #9 of 12 (827 views)
Re: Front Strut Question - Just had new installed Sign In

I still don't like it now don't buy it. If there are 4 versions that are all the same and fine for any then why have different ones at all? Doesn't add up - there's a difference that must matter and bet now you said not aligned yet would show it,


T
PS: Measure height now if only a tape measure to lip on inside wheel well trim, both wheels pointed straight ahead and after it rolled some to check. Bet it's off........



Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Apr 12, 2016, 2:02 PM

Post #10 of 12 (821 views)
Re: Front Strut Question - Just had new installed Sign In

The height isn't going to tell you anything. Someone either left an extra spacer or left one out.
They should be exactly the same on both sides. They are the same part number.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Apr 12, 2016, 2:25 PM

Post #11 of 12 (818 views)
Re: Front Strut Question - Just had new installed Sign In

HT - totally agree - it isn't right for whatever reason. ? Ready to install jobs w spring already then this. NO. True, it may sit right but not bottom at same spot. In short, wouldn't leave it that way, T


Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Apr 12, 2016, 5:38 PM

Post #12 of 12 (795 views)
Re: Front Strut Question - Just had new installed Sign In

That definitely isn't right. I agree something is missing from the strut mount. Quick struts suck. We have had nothing but trouble with them, so we stopped using them a long time ago. Does the shop still have the old strut assemblies?





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.

(This post was edited by Discretesignals on Apr 12, 2016, 5:40 PM)






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap