Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

Car stalling at idle, especially after a cold start


  Email This Post



currymonster
New User

Sep 24, 2020, 11:22 AM

Post #1 of 2 (112 views)
Car stalling at idle, especially after a cold start Sign In

I drive a 2008 Hyundai Sonata Limited (V4 4-speed auto). It has about 70,000 miles on it. I’ve had an on and off issue for years where every 500 miles or so, the engine will stall at a red light, but will start right back up. Tried to have the dealer diagnose the issue to no avail. They couldn’t replicate it.
Fast forward to this July, something happened that made the engine stall every time the car idled. Took it into the shop and turns out it was the crankshaft sensor, which I had replaced. Thought the problem was fixed until 3 weeks later, it happened again. Car stalled at a red light a couple minutes after starting the engine.
Lately, I’ve picked up on a couple trends. It only seems to happen after a cold start, so when I don’t drive for a couple days. It seems to take a while to start. I hear the engine cranking, but don’t see it on the tach. Sometimes, it immediately shuts down after a cold start. Also, over the past couple weeks, I’ve lost acceleration power twice on the highway. No check engine lights or anything. I had to pull over and restart the car and it ran fine afterwards.
I was convinced it was a wiring issue with the crankshaft sensor, but I took it to the shop today and the mechanic said the crankshaft was fine. He suggested it was a transmission issue, which I don’t really understand. I’ve done reading on potential causes and I’ve seen the fuel pump and the crankshaft as the two big ones. I’m honestly so frustrated and lost about what to do with my car. I feel like I’m close to a fix, but I’m considering selling for something else to get rid of the problem. Any suggestions on what could be going wrong?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 24, 2020, 11:48 AM

Post #2 of 2 (110 views)
Re: Car stalling at idle, especially after a cold start Sign In


Quote
I hear the engine cranking, but don’t see it on the tach.


That issue points to either a problem with the Crankshaft Position sensor or the PCM itself. The part about not setting any codes leans toward a faulty PCM.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap