Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

Accelerator problem Ford RS


  Email This Post



ivntiamzon
New User

Apr 24, 2014, 2:20 PM

Post #1 of 2 (962 views)
post icon Accelerator problem Ford RS Sign In

Move my thread if I'm wrong

Last night I was driving it was fine until I was near home. I'm using a ford rs manual. So first press clutch primera then acclerate release clutch. But now whenever I release clutch and press accelerator it gas up the gauge of accelerator goes up but it doesn't run, it runs really slow and the engine throttles up but it doesn't run like the normal ones. Please I'm so noob in here. But I can listen and fix it on my own.

Ford Rs
Dohc-16 valve


(This post was edited by ivntiamzon on Apr 24, 2014, 2:21 PM)


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Apr 24, 2014, 8:29 PM

Post #2 of 2 (931 views)
Re: Accelerator problem Ford RS Sign In

Sorry if I'm misunderstanding you but sounds like you let up on clutch (foot off pedal) and engine RPMs go up but vehicle doesn't speed up? If so that's just classic for a worn out clutch. When one does that most will just fail quickly and vehicle will not move at all.


Not all but most clutch linkages are hydraulic and not adjustable. There should be "freeplay" at the top you could push with your finger and if not it's self destructing and you don't have much time so don't wait on this,


T







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap