Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

99 lancer lost power while driving now won't start


  Email This Post



Damsel n Distress
New User

Aug 29, 2014, 2:54 AM

Post #1 of 2 (871 views)
post icon 99 lancer lost power while driving now won't start Sign In

99 lancer 4 speed auto lost engine power while cruising at 60 km/h still had enough to creep the last 200 metres home but had no acceleration. Came to a stop put car in nuetral and could smell a synthetic smell (best discription it wasn't oil or fuel though) . Turned engine off looked in engine bay and under, there was no fluid leaking. Tried to turn engine over but only turned over few times without firing then made a loud thud noise so I stopped. Please help I would just like some idea what is wrong. Appreciate any input Smile


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Aug 29, 2014, 4:01 AM

Post #2 of 2 (861 views)
Re: 99 lancer lost power while driving now won't start Sign In

Could use what car maker and engine this is not just a model which could be different than ones sold to US? Trusting your sense of smell for odor a bit could be electrical or rubber perhaps you noticed.


The "bang" concerns me. Look again for belts, and lower damper (lowest pulley) without cranking engine if it's out of line OR if belts are off. It should have warned you with lights even for the 200 meters IMO of something.


IDK - service belt(s), timing belt if used on this broken maybe electrical wiring insulation. I wouldn't try to crank this again till more is known,


T







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap