Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









95 blazer a/c blows out defrost vents


  Email This Post



kensoncustom
User

Jul 7, 2012, 5:56 PM

Post #1 of 4 (1068 views)
Shortcut
post icon 95 blazer a/c blows out defrost vents Sign In

hello i have a 95 chevy blazer 4.3 vortec defrost blows nice and cold.i found a vacume hose hanging off the ball reservoir under hood no vac hose scamatic.any one got a picture?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jul 7, 2012, 6:03 PM

Post #2 of 4 (1056 views)
Shortcut
Re: 95 blazer a/c blows out defrost vents [In reply to] Sign In

It's not much of a picture but they are usually pretty easy to see the routing.






~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Discretesignals
Veteran / Moderator
Discretesignals profile image

Jul 7, 2012, 6:17 PM

Post #3 of 4 (1042 views)
Shortcut
Re: 95 blazer a/c blows out defrost vents [In reply to] Sign In

I'm sure it didn't fall off for no reason. The vacuum hoses are probably crusty and need replacing.





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.


kensoncustom
User

Jul 7, 2012, 8:29 PM

Post #4 of 4 (1019 views)
Shortcut
Re: 95 blazer a/c blows out defrost vents [In reply to] Sign In

u r right someone put what looks like a i/v tube more than likely didn't last a day. thanks for the info HAPPY 4TH




95 blazer a/c blows out defrost vents


  Email This Post
 
 






Latest Forum Post

hello. i'm at my wits end and out of money. my kia sedona was overheating so we...


I have bumpers ,taillights, brackets, body chrome, dr handles, disk brake calipe...


My 1998 gmc jimmy won't hardly pull what is wrong with it took it mud riding and...


Can anyone tell me how to get the large plastic cover off the engine on this VW ...


I have a 1996 Mercury Village GS. The front blower motor stopped working. I di...


I have a 1995 Mitsubishi Expo,4-cycle engine, with 118,000 miles. I drive it les...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics