Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

94 s/s s/10 lost oil pressure and oil all over engine


  Email This Post



chrisalisa
New User

Jun 27, 2014, 12:21 PM

Post #1 of 7 (1037 views)
94 s/s s/10 lost oil pressure and oil all over engine Sign In

hi, i have a 94 chevrolet s/10 s/s. it has 178,000 miles on it, and has the 4.3 vortec engine. i was on my way to work and i seen the check gauges light come on. looked to see my oil pressure was bottomed out and i noticed blue smoke (oil smoke) coming out the back. i dont think it was coming from the exhaust due to the fact that when i got to work i lifted the hood and there was oil all over the front of the engine from the radiator to the oil pan. i lost no horse power, i had no knocking or rattling, no over heating. i pulled into work and went to turn it off and i heard a faint ticking. i dont think it slung a rod, could it be my oil sending unit, or maybe some crazy oil pump issue. had no trouble before this. truck runs like new till this happened. any ideas would be appreciated. i have not gotten it towed home yet so i havent had a chance to look it over. just wanting some ideas for when i do get it home. thanks again


Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Jun 27, 2014, 12:24 PM

Post #2 of 7 (1034 views)
Re: 94 s/s s/10 lost oil pressure and oil all over engine Sign In

Your guess is good as ours. A visual inspection should find the culprit.





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.


chrisalisa
New User

Jun 27, 2014, 12:45 PM

Post #3 of 7 (1026 views)
Re: 94 s/s s/10 lost oil pressure and oil all over engine Sign In

lol, yea im ready to figure it out. i have built several engines and some crazy things happen but i have never seen this. really weird. ill keep yall posted on what i find. itll be sunday probably before i get to look it over.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jun 27, 2014, 12:56 PM

Post #4 of 7 (1019 views)
Re: 94 s/s s/10 lost oil pressure and oil all over engine Sign In

Tough engine IMO + you might just luck out? Duh - find what blew out first and fill w cheap oil first to see. FILL NEW OIL FILTER WITH OIL FULL AS BEST YOU CAN!


If this has a remote oil filter anything to do with that could do that or somehow any oil cooler or lines to an oil cooler. I doubt oil filter could get oil sprayed up high but should be obvious. Oil pressure sender I think is on back near distributor area and can blow but again shouldn't blow all the way forward from there.
T


I wouldn't spend big bucks till proven OK on a fix of the leak. Good luck, you need some about now,


Cross fingers that it just may snap out of it and be fair at best with some impact from that at a minimum.



loin_lord
User
loin_lord profile image

Jul 5, 2014, 6:33 AM

Post #5 of 7 (947 views)
Re: 94 s/s s/10 lost oil pressure and oil all over engine Sign In

I've got a 98 s10 with a vortec 4.3. At first, I was gonna say check the tightness of your oil filter, since it is fairly close to your exhaust and that would cause the smoke. Then I reread your post and mentioned that oil was collecting up front by the radiator as well... I've never had this problem myself, but maybe the front main seal (where the crankshaft meets the pulley that drives the belt... not sure what the formal name is) somehow went out and the air movement blew the oil all about up front.

Sorry to hear this. Those 4.3's are good engines. Hopefully it isn't major and you can get more miles from it.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jul 5, 2014, 6:45 AM

Post #6 of 7 (938 views)
Re: 94 s/s s/10 lost oil pressure and oil all over engine Sign In

Haven't heard back from OP yet so dunno what was found yet. Oil filter probably wouldn't spray up to radiator on this engine UNLESS a remote one perhaps.


Front seal? Probably not. I've seen them leak like they're missing just by hitting brakes then stop other times?


This one has to be obvious with that mess as it was described,


T



Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jul 5, 2014, 7:46 AM

Post #7 of 7 (930 views)
Re: 94 s/s s/10 lost oil pressure and oil all over engine Sign In

Oil doesn't splash forward. It only runs down and back so it you have oil in front of the radiator, it can only be a cooler or something mounted up there but this thread isn't about your truck so we'll drop that idea.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap