Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




94 JEEP GRAND CHER LAREDO FUEL/IGNITION PROB


  Email This Post



Guest
Anonymous Poster
angela@gfsi.net

Jun 2, 2007, 3:11 AM

Post #1 of 2 (490 views)
Shortcut
94 JEEP GRAND CHER LAREDO FUEL/IGNITION PROB Sign In

I have a 94 Jeep Grand Cherokee Laredo. It has 130, 000 miles, auto transmission, 2WD, 6 cyclinder. I have started to have problems with starting the vehicle. I replaced the battery after it was tested as dead and unchargable. Afterwards, it would start after trying twice. I replaced the spark plugs, the fuel filter, and the distributor cap and rotor. After this maintenance (which needed to be done judging by the wear on the old parts), the problem continued. It refused to start earlier today, but a starter fluid got it to start. Later in the day, it would not accelerate up a hill. It did not seem to be getting any fuel. The next start, it was extremely rough, did not get any fuel to move, and then it died. It will no longer start. I have not noticed any fluid leaks or any odd sounds.

Any help would be greatly appreciated!!


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jun 2, 2007, 5:53 AM

Post #2 of 2 (487 views)
Shortcut
Re: 94 JEEP GRAND CHER LAREDO FUEL/IGNITION PROB [In reply to] Sign In

The items you already replaced are good maintenance so no loss there. This problem sounds like low fuel pressure. Check that. You may hear the buzzing of the fuel pump just buzzing away when it should just build pressure then stop with key just in run position.

Fuel pump would be the common failure for this but there's more that could be causing this like pressure regulator, or a wrong signal to computer telling the vehicle is doesn't need any more fuel,

T
_________________________________________
Long retired now




Advertising


  Email This Post
 
 






Latest Forum Post

1990 chevrolet c1500 4.3 tbi 110k recently replaced motor w/ a 93 4.6 had a fe...


I am having a random repeating problem with a 2007 Honda Civic. The fuse that op...


Hi everybody not mechanical at all PLEAE HELP I HAVE A 2000 FORD TAURUS SE,,,B...


2003 Chrysler mini van. 3.3 ltr 133600 mi while driving, engine light came on b...


driver side spark plugs was no problem-3 out and 3 new ones in,now it's time fo...


1998 Chevy 3500,6.5 diesel,automatic trans,4WD,1ton dump truck. Problem:Driving ...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy