Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

93 XJ Cherokee crank but no start


  Email This Post



carverdave
Novice

Sep 10, 2015, 6:37 AM

Post #1 of 16 (1103 views)
93 XJ Cherokee crank but no start Sign In

Hi folks, I've been having a hell of a time getting to the source of this issue.
My Jeep died on me, just shut down while driving and wouldn't restart. found a badly cracked 90 degree elbow on the fuel pressure regulator and wet with gas on the back side of the regulator. Got pulled home and after a while it started up fine and ran for a few minutes before the engine killed again, but wouldn't restart till it sat for about a half hour or so, and would only idle for about a minute and die. I replaced the fuel pressure regulator and rubber elbow, but no change.

Got a friend with a pressure regulator over here and was able to test pressure on one of the occasions that it started. idle pressure was around 30, but right after it died pressure would drop off fast (within a minute). Eventually, it got to the point where it would crank, but not start even after sitting for hours.

I replaced the ignition coil, cause I've had issues with that a couple times and it's cheap. replaced the CPS a couple years ago with an $80 OEM CPS which turned out to be a coil problem, so I put the old CPS back in. New cap and rotor, still crank and no start, but now it was sounding like it just wasn't getting gas so I put the pedal to the floor and it finally started. I kept my foot lightly on the gas for a while and it kept running. let off the gas and it idled without stalling. let it run for about 10 minutes and everything was fine. Drove it to the store and back (about a 10 mile round trip) and no problem. shut it off and it started up right away.

I was thinking it might be the fuel pump. I can hear it run for a couple seconds when I turn the key, but the fast pressure drop suggested a bad check valve in the pump anyway. Drove it the next day to the auto parts store and used their pressure gauge. #30 at idle and quick drop off on shutdown. got a new fuel pump and drove home. checked codes and had 51. changed fuel pump after a hell of a time getting the old lock ring off. With the new pump installed I got crank, but no start. Pulled the hose off the input to the fuel pump and it was dry as a bone. I could hear the new pump running like it should with the key turned, but it wasn't pumping. I put the old pump in and it started fine.

This is currently my only vehicle and so while it was running I had to go get some thing done. It's been about a week now and I've driven it over 600 miles with no issue, and the 51 code is no longer there, but a couple days ago on my way to the gas station I discovered fuel spraying out the side of the fuel pressure regulator seal. Took it off when I got home and found that the O-ring was nearly sliced in half. I put the O-ring from the old regulator on, but now I'm back to the crank, but no start problem. It fired a couple times, but never got it running. Got a new fuel pump, fuel filter, and battery. This time the new pump is getting fuel to the filter at least, but still no start. I don't know where to look at this point.

Here's everything I replaced since this all started:
ignition coil
cap and rotor
spark plugs
battery
fuel pressure regulator
fuel filter
fuel pump
cleaned IAC and throttle body
switched CPS with older CPS

I'm done throwing money at it till I can narrow down a cause.
I ordered a spark tester, fuel pressure gauge, and compression tester which should be here tomorrow, but every day this things not running I'm losing money by not getting to my jobs.

Any Ideas where to look next?
Thanks


datsun girl
New User

Sep 10, 2015, 8:14 AM

Post #2 of 16 (1094 views)
Re: 93 XJ Cherokee crank but no start Sign In

so if your pressure drops for fuel and you blocked off or pinched off lines and it still dropped then u need to test your injectors hun. they will cause this. if you can get it to start u'll need a long screwdriver to use as a stethoscope listen for click should be consistent no delays or pauses check each individually.


Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Sep 10, 2015, 8:26 AM

Post #3 of 16 (1090 views)
Re: 93 XJ Cherokee crank but no start Sign In

You should read this and post your results:

(these things need to be checked when the engine doesn't want to start. More than likely it won't be a compression issue since the problem is intermittent).

http://autoforums.carjunky.com/...LL_NOT_START_P75655/





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.


carverdave
Novice

Sep 10, 2015, 9:32 AM

Post #4 of 16 (1083 views)
Re: 93 XJ Cherokee crank but no start Sign In

I get good spark from the ignition coil and the distributor.
If I can get it to start I will certainly try the screwdriver stethoscope idea. I want to disconnect the fuel line from the fuel rail to see if it's getting fuel there, but the quick connect fittings are considerably less than quick at this point. If I damage them trying to get the fuel line off would a hose clamp be sufficient to reattach the fuel line, at least temporarily?


kev2
Veteran
kev2 profile image

Sep 10, 2015, 11:49 AM

Post #5 of 16 (1077 views)
Re: 93 XJ Cherokee crank but no start Sign In

which engine - this is for a 4.0L?

NO codes?
Spark at ALL plugs? how do plugs look -wet,dry,BLACK, tan?
Fuel pressure? PSI and then with KOEO observe leakdown...
Injectors- noid light -1)flashing 2) on steady 3) not on not flashing -?
using a fuel gauge on the connector will be enough without disassembling rail...

Check the engine oil for evidence of excess fuel- just to be safe.


PS jeeps are easy- start with BASICS l


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 10, 2015, 1:00 PM

Post #6 of 16 (1074 views)
Re: 93 XJ Cherokee crank but no start Sign In

No, no hose clamps. The idea is not to damage the line.

You need to follow those instructions completely with no short cuts.

Make sure you use a fuel pressure gauge, don't guess at the pressure.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



carverdave
Novice

Sep 10, 2015, 2:55 PM

Post #7 of 16 (1066 views)
Re: 93 XJ Cherokee crank but no start Sign In

No codes. I don't have a scanner, just the check engine trick. I get 12 battery recently disconnected, and 55 end of codes.

I changed plugs, but looking at the old ones, all where dry. Front of the engine driest and kind of tan I guess. None are black but progressively darker and wetter toward the back of the engine. spark from all of them.

Won't have a pressure gauge till sometime tomorrow (yay... another day stranded)

This is a 4.0L inline 6

I don't have a noid light

Oil looks fine, but could use a quart.

Thanks for the replies so far


carverdave
Novice

Sep 11, 2015, 8:21 AM

Post #8 of 16 (1049 views)
Re: 93 XJ Cherokee crank but no start Sign In

Still waiting for my fuel pressure gauge to get delivered, so I took off one of the fuel injector connections to do a multi meter reading. I had my meter set to 20V DC with the black probe connected to the negative battery post and the red to the connector socket. I get 0.05V ? with the key in the on position. ohms test on the injector prongs is 15 which sounds about right, but I don't know what's going on with the 0.05. Put the meter on the battery and I get 12.5 volts.


carverdave
Novice

Sep 11, 2015, 8:38 AM

Post #9 of 16 (1046 views)
Re: 93 XJ Cherokee crank but no start Sign In

I did the same meter test on the CPS connector and got 5 volts as it should be.


kev2
Veteran
kev2 profile image

Sep 11, 2015, 9:38 AM

Post #10 of 16 (1041 views)
Re: 93 XJ Cherokee crank but no start Sign In

You have good spark at all 6 ?

sounds like fuel isssue - pressure is important- @31psi* ? running and remove vac line from regulator iy should increase @8-10 psi.

the injectors have 2 wires- SO unplug the injector -
UNPLUG INJECTOR with KOEO.
One wire will have 12v same color wire all injectors will have 12v.
The other wire is control/signal...different color each injector- NO voltage, not grounded.
SO far what is found?




* my quick ck BUT I would like another techs opinion....


carverdave
Novice

Sep 11, 2015, 10:45 AM

Post #11 of 16 (1037 views)
Re: 93 XJ Cherokee crank but no start Sign In

I have spark on all 6 plugs.
My pressure gauge just showed up and I have no fuel pressure. Pump turns on for a couple seconds and shuts off the way it's supposed to. If I turn the key on/off on/off the pump will run twice, but no more than that. Checked the fuel pump and ASD relays earlier today and could hear the click from both.


Double J
Veteran / Moderator
Double J profile image

Sep 11, 2015, 12:24 PM

Post #12 of 16 (1030 views)
Re: 93 XJ Cherokee crank but no start Sign In

Do you have this 'Fuel Pump Ballast Resistor Bypass Relay' on your vehicle?



They had a concern with Fuel Pump noises on these and issued a TSB to eliminate it from the circuit and install an updated Fuel Pump module to eliminate the noise. When eliminated ,with the new design module, it allowed system voltage to the pump at all times.

But you may still have it in the circuit.



Eliminating it meant to "Cut the 18 gauge dark blue wire at pin 5 of the relay and seal the harness end of the wire ." So if the bypass relay is still there, check to see if the wire was cut or not. If not, may be an area to check into.


carverdave
Novice

Sep 11, 2015, 1:08 PM

Post #13 of 16 (1018 views)
Re: 93 XJ Cherokee crank but no start Sign In

Yes, I do have that bypass relay, but I've discover some new things here.

I put the old fuel pump in again and it started right up. Had #31 psi at the rail on idle, pulled the hose off the regulator and it jumped to about #45. shut it off and the pressure held steady for a while and slowly dropped to about #20. It's not the old fuel pump, but the second new one I bought is junk. 2 in a row.

I did the screwdriver stethoscope on the injectors and they all sound fine.

It's idling really rough and there was fuel dripping from the fuel pressure regulator. After I shut it down and the pressure held at about #20 for quite a while I heard a sigh of air come out of the fuel pressure regulator seal and the rail pressure dropped to zero.

I'm guessing it's the regulator.


Double J
Veteran / Moderator
Double J profile image

Sep 11, 2015, 2:21 PM

Post #14 of 16 (1006 views)
Re: 93 XJ Cherokee crank but no start Sign In

So you have 2 bad new pumps and a bad new regulator?


Quote
Here's everything I replaced since this all started:
ignition coil
cap and rotor
spark plugs
battery
fuel pressure regulator
fuel filter
fuel pump
cleaned IAC and throttle body
switched CPS with older CPS


Quote
the second new one I bought is junk. 2 in a row.

Where are you getting these parts?


carverdave
Novice

Sep 11, 2015, 4:16 PM

Post #15 of 16 (1002 views)
Re: 93 XJ Cherokee crank but no start Sign In

I live kinda out in the woods and the nearest auto parts store is about 20 miles away. Parts Plus. I don't have a lot of other options. It's not just a skip down the road to the local Auto Zone. Since the Jeep is running I went down and returned the fuel pump. He tried to give me an exchange and I said "No way". I'm not going with the third time's a charm on a $70 pump.

I don't know what the hell was up with the Pressure regulator. I have the new one in there, but with the O-rings from the old regulator. They'er not in great shape, but the weren't sliced to pieces like the one's that came with the new one.

I put the pressure gauge on the rail before I shut down the jeep when I got home. It's been about 20 minutes and the gauge is at about 25#.

The idle is still rough, and there's an occasional hiccup here and there while driving. I'd like to clear that up, but not entirely sure what to look at.


Double J
Veteran / Moderator
Double J profile image

Sep 11, 2015, 6:14 PM

Post #16 of 16 (997 views)
Re: 93 XJ Cherokee crank but no start Sign In

Don't have one of those here yet but have enough of the others just like it, Autozone, Advance, Pep Boys, they're all selling pretty much the same stuff.


Quote
but the weren't sliced to pieces like the one's that came with the new one.


O-rings get damaged during installation. I doubt they were sliced to pieces out of the box....LOL...

Anyway, sounds like you got it solved.

You're doing OK, as far as the other things, start with the basics.


(This post was edited by Double J on Sep 11, 2015, 6:15 PM)






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap