Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









88 firebird wont start


  Email This Post



Guest
Anonymous Poster
jenniferbraun@charter.net

Jun 17, 2006, 8:10 PM

Post #1 of 4 (777 views)
Shortcut
post icon 88 firebird wont start Sign In

i have a 88 firebird that wount start i am flustered i turn the key and have lights and radio.but nothing else no noise or nothing.help!!!!!!!!!!!!!!!!!


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jun 17, 2006, 10:27 PM

Post #2 of 4 (771 views)
Shortcut
Re: 88 firebird wont start [In reply to] Sign In

Std or automatic? There are safety switches that prevent power from engaging the starter. Could be some other things too. T
_________________________________________
Long retired now


Guest
Anonymous Poster

Jun 18, 2006, 7:50 PM

Post #3 of 4 (767 views)
Shortcut
Re: 88 firebird wont start [In reply to] Sign In

it is an auto


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jun 19, 2006, 12:50 AM

Post #4 of 4 (762 views)
Shortcut
Re: 88 firebird wont start [In reply to] Sign In

OK let's go back. ( forget about the safety switch for now )

I think you have a problem with the starter motor. There's so little info about this it's just a wild guess. If you have a volt meter check for voltage drop when trying to start. If not try turning on interior lights and see if they dim while trying to start.

Another real pro thing to try (just kidding) is hitting the body of the starter with a hammer not too hard and if it starts up junk the starter.

Hey !! Stay safe. Keep your bod out of the way as the car just may start and that's fine but NOT with you in harms way.

I don't know your level of skills for this or any testing DON'T! Safty first, $$ second. T
_________________________________________
Long retired now




88 firebird wont start


  Email This Post
 
 






Latest Forum Post

I was changing the thermostat on ford f150 and the bolt that holds the thermosta...


Hi Guys. I have a 1993 Toyota 4 Runner. While i was out driving today i notice t...


2003 Nissan Altima 2.5L 150,000 While driving, I occasionally and momentarily l...


1993 Geo Tracker 4x4 with 5 spd manual transmission. 130,000 miles. The battery...


When the car was inspected by a mechanic I was told that the problem is the ball...


There are lots of 134A products on the market. Is there a preferred or better...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics