Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




83 Chevy Electrical issue


  Email This Post



for3300
New User

Jan 8, 2010, 3:20 AM

Post #1 of 2 (766 views)
Shortcut
83 Chevy Electrical issue Sign In

I took out my engine and replaced several parts(nothing inside the engine). I also redid some of the wiring, because the wires where in bad shape. I have everything hooked back up now. When I turn the key nothing at all happens. no clicks or anything. The battery, starter, ignition switch and neutral safety switch are new. Test light shows battery and starter are getting power. I jumped the starter and it tried to start. I get nothing when putting a test light on the ignition switch or neutral safety switch wires. Head lights come on. A fuse that has "BAT" and "ECM IGN" have power when I test with a test light.

How can I close a possibly open ignition circuit?
What wire gives the ignition switch power so I can investigate?

This is my last step before getting my truck back on the road again please help.


re-tired
Veteran / Moderator
re-tired profile image

Jan 8, 2010, 5:13 PM

Post #2 of 2 (753 views)
Shortcut
Re: 83 Chevy Electrical issue [In reply to] Sign In

You did not state which model of chevy truck or eng size so i cannot reference a wiring diagram. BUT , here are some generic things to check .Clean grounds both the cable end and the mounting point . Did you happen to repaint the frame im the eng compartment ? You may have enough of a ground to light headlamps but it takes a lot mor to crank an eng .


LIFE'S SHORT GO FISH




Advertising


  Email This Post
 
 






Latest Forum Post

I will try and be as clear as I can. 1999 Fleetwood tioga (ford e350) I turn my ...


I have a 2006 Nissan maxima 3.5 There is nothing wrong with it but I was wonde...


blower motor did not work i pulled it out and tested it it worked i put it back...


So I have a 1999 ford escort zx2 it has the 2.0 i4 doc engine with the 5 speed t...


Hope everyone is doing well. Now that work has slowed down I decided to take a l...


I have a 91 Chevy pick up with a 4.3l v6 and 180,000 miles everything is origina...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy