Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

2010 Kia Forte engine sputtering when idling


  Email This Post



brad4521
New User

Jan 8, 2017, 4:56 PM

Post #1 of 2 (1578 views)
2010 Kia Forte engine sputtering when idling Sign In

This problem has been occurring for several months now, progressively getting worse. It all started when I would try to turn on my car. My car would successfully turn on, however, it barely sounded like it was running/getting enough fuel. This would only happen every couple of weeks, so I continued driving it. When this problem would occur I would turn it off and then back on (which would make it start perfectly). This issue got worse when the check engine light came on one day (while it had a bad start) and I got it towed to a repair shop. The code indicated that it was the oxygen sensor, which they replaced. They also told me that there was gas in my oil, which I replaced.

About a week later the problem occurred again, this time turning it off and on did not work. During this day I was in two hr parking, so I was continually moving my car. The last time I moved it that day a new problem occurred. When I tried turning it on with the key, it turned over a lot and eventually started. For some reason my radio was off and I had to re calibrate all my music channels. When this occurred I knew there was a good possibility that my car would poorly start up the next time I tried it, which it did.

I left my car overnight and was prepared to get it towed once again. However, it started perfectly, so I drove it to the same repair shop. They have had my car for several weeks and they are turning it off and on trying to catch it acting up, which they have not been able to do yet.

For clarification, when my car would sputter while idling, it was undriveable and sounded like it would turn off at any moment. I never had a problem when I was able to drive it.

Any guidance to this issue would be greatly appreciated!


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jan 9, 2017, 12:33 AM

Post #2 of 2 (1567 views)
Re: 2010 Kia Forte engine sputtering when idling Sign In

I always have a problem when a shop/garage/repair place or call them what you want keeps a vehicle for "several weeks" and has no diagnosis! It's really up to them to send it along but you should by now think of yet another place as that's plain too long for figuring out a no start condition. An hour should do.


Codes: FYI they don't tell you WHAT to replace rather the circuit with a problem. There's very real problems with fuel in the oil such as rapid engine wear out, oil level could spike to way too full.


YOU saying you had to reset radio stations is near certainly from excessive attempts to start this lowering battery so low it's reset all memory except probably still has codes if it ran at all that are still coming right back that current shop can't read so have to suggest another with the history you just stated.


The only thing you should be questioning is why this is taking so long to figure out by techs who if they can't find the problem should at least say so to you so you can find another shop that can handle this as apparently the current one can't,


T







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap