Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

2004 Nissan Frontier 4wd se


  Email This Post



Peanut99
Novice

Nov 5, 2018, 8:21 AM

Post #1 of 11 (197 views)
2004 Nissan Frontier 4wd se Sign In

Cruise control kicks off when I turn headlights on.changed out headlight switch,cruise and brake light switches.didn’t help.also the cruise control set light blinks when the headlights are on at speeds of 35mph and above. Help please


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Nov 5, 2018, 8:37 AM

Post #2 of 11 (189 views)
Re: 2004 Nissan Frontier 4wd se Sign In

Arggh - just first the question is this issue new or you just acquired this vehicle? There are MANY times NOT to use cruise control up to illegal impossible to know just where.


Up and coming is anytime wipers are on cruise will shut off. Oh my will that be a rule or law for everything or just an area? Can't know so suggest if this is a new vehicle to you, you check and see what it's supposed to do and when,


T



Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Nov 5, 2018, 8:49 AM

Post #3 of 11 (184 views)
Re: 2004 Nissan Frontier 4wd se Sign In

Does this have any aftermarket equipment installed such as trailer wiring or brakes?

There is a cruise control module that monitors the brake pedal switch. If it sees 12 volts, it assumes the brake pedal is being depressed. Maybe you have a short in the brake lamp circuit to parking light circuit causing the cruise control module to disable cruise. When you turn on your running lights what are your brake lamps doing?





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.


Peanut99
Novice

Nov 5, 2018, 11:48 AM

Post #4 of 11 (164 views)
Re: 2004 Nissan Frontier 4wd se Sign In

Dose have after market trailer wiring harness,but it been there at least 12 yrs. running lights normal when lights are on. Brake lights and turn signal working normal also


Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Nov 5, 2018, 12:00 PM

Post #5 of 11 (155 views)
Re: 2004 Nissan Frontier 4wd se Sign In

If you unplug the brake switch connector is there any voltage on the brown/red wire with the headlamps on?





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.


Peanut99
Novice

Nov 6, 2018, 8:47 AM

Post #6 of 11 (105 views)
Re: 2004 Nissan Frontier 4wd se Sign In

Just checked switch connector.shows v 5.16 when headlights are turned

In Reply To


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Nov 6, 2018, 9:06 AM

Post #7 of 11 (95 views)
Re: 2004 Nissan Frontier 4wd se Sign In

I'll trust the colors of wire to check were correct should be power out to the bulbs not 5.5V is computer info. NO if it detects a fault the ''default" is shut down.
Sure even 5.5v detected would shut it down question is why or I suggested a normal for a few not to work,


T



Peanut99
Novice

Nov 6, 2018, 9:25 AM

Post #8 of 11 (90 views)
Re: 2004 Nissan Frontier 4wd se Sign In

Red/brown was one checked. With ohm meter. 0 reading with lights off. Lights on shows 5.16 v


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Nov 6, 2018, 9:35 AM

Post #9 of 11 (86 views)
Re: 2004 Nissan Frontier 4wd se Sign In

IMO still enough think it's got brake lights ON.
? You mean you used a volt/ohm meter not just some ohm meter? You were looking for just voltage not ohms for this,


T



Peanut99
Novice

Nov 6, 2018, 11:28 AM

Post #10 of 11 (64 views)
Re: 2004 Nissan Frontier 4wd se Sign In

Sorry for not being political correct,but you knew. What I was refuring to. There are no brake lights on and all lights are in properly working.also disconnected after market trailer wiring harness.still same issue


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Nov 6, 2018, 12:18 PM

Post #11 of 11 (53 views)
Re: 2004 Nissan Frontier 4wd se Sign In

There was power there, lights wouldn't work with 5.5v you only might find that at sockets of bulbs too.
The aftermarket trailer wiring? How clear is it that it's defeated or disconnected? What was done to make trailer wiring if you know? Can't say if this had a plug waiting and was used or wires to actual lights just tapped into? Was it just a "flat" four wire or more involved. How spliced and sealed now undone there's room for assorted problems just with that.
That voltage goes OUT with headlights off and it works is the key clue for the hunt for where it picks that up to fix it if you wish cruise to work with headlights on,


Tom







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap