Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

2003 Olds Alero 3.4 v-6 over heating issues


  Email This Post



cjjenkins87
New User

Feb 26, 2013, 4:50 PM

Post #1 of 4 (3809 views)
2003 Olds Alero 3.4 v-6 over heating issues Sign In

All
I have a 2003 Olds alero with a 3.4 v-6 with about 120000 miles. here is the issue:
About a month ago we were driving the car with the heater on (nice and warm). all of a sudden the output turned cold and the temp gauge started to rise ( it got a little above the middle of the gauge). all of a sudden the heater started blowing warm air again and the temp gauge dropped back down (a little below middle). it did it again so I took it home and changed the thermostat and it was fine for about 2 weeks. then it started doing it again same thing as above. it started blowing cold air but as soon as the temp gauge got a little above center it starts blowing hot air again and the gauge dropped back below center. I then flushed the system and filled it with 50/50 anti freeze and for 2 days it worked great. then it started doing it again. when I drained the fluild before I flushed it the anti-freeze looked clean and when I drained the flush it also looked clean. I am thinking about replacing the water pump and thermotat again but I am unsure. any ideas?
thanks


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Feb 26, 2013, 5:06 PM

Post #2 of 4 (3795 views)
Re: 2003 Olds Alero 3.4 v-6 over heating issues Sign In

Sounds like you have a leak somewhere and you are getting air pockets. You need to pressure test the cooling system to find out where the coolant is going. This engine is notorious for both intake manifold gasket leaks and blown head gaskets so don't drive it that way.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



cjjenkins87
New User

Feb 26, 2013, 5:49 PM

Post #3 of 4 (3771 views)
Re: 2003 Olds Alero 3.4 v-6 over heating issues Sign In

Thanks for the advice, that is the strange part. I am not loosing any fluid in the syste, it is still where I left it at. any other thoughts adn thanks


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Feb 26, 2013, 6:09 PM

Post #4 of 4 (3766 views)
Re: 2003 Olds Alero 3.4 v-6 over heating issues Sign In

You are. You just don't see it because the heater is the first thing to get an air pocket. That's why it got better after the flush.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap