Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help!


  Email This Post



sh0wtym3
New User

Jul 10, 2012, 9:47 PM

Post #1 of 6 (3047 views)
Shortcut
2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help! Sign In

2003 Chrysler 300M
3.5L V6 engine
111304 miles

Hey everyone,

When I first start to drive my car its fine, but often when I decelerate (especially when decelerating fast or going up an incline) the engine will jerk and then remain in 2nd gear until I turn it off and back on again. I read online that this is called "limp-in" mode, and is a safety feature when something is going wrong. However when I drive the car in "autostick" mode, this doesn't happen nearly as often.

I took the car to my local dealership and they said they didn't know what the problem was, and they said they needed to take the transmission apart ("transmission overhaul") to find out what parts are needed. This will cost me $1,682.69 which I don't have, plus the cost of labor and whatever part needs to be replaced. Then below that quote they wrote "this does not include R&R complete transmission assembly fee - $3524", which I'm guessing means they are going to charge me another arm and leg to put it back together!

Do I really need a transmission overhaul? Is there some cheaper alternatives I can try to fix it? Here are the error codes along with the notes the technician wrote down:

P0562 - "Low battery"
P0952 - "Auto stick input circuit low"
P0731 - "Gear ratio error in 1st"
P1790 - "Fault immediately after shift"
P0841 - "LR pressure switch sense circuit"
P0871 - "Overdrive pressure switch sense circuit"
P1776 - "Solenoid switch valve located in LR position"

Any help would be much appreciated!


(This post was edited by sh0wtym3 on Jul 10, 2012, 9:48 PM)


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jul 10, 2012, 9:58 PM

Post #2 of 6 (3040 views)
Shortcut
Re: 2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help! [In reply to] Sign In

Even if you do, you can get it done a lot cheaper than that. Use references to find a reputable independent transmission shop.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



nickwarner
Veteran / Moderator
nickwarner profile image

Jul 10, 2012, 11:20 PM

Post #3 of 6 (3000 views)
Shortcut
Re: 2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help! [In reply to] Sign In

Agree with HT. The price is way too high. Shop around. I think you do need a trans especially with 2 of the codes in that list but no reason it should cost that much.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jul 11, 2012, 6:14 AM

Post #4 of 6 (2984 views)
Shortcut
Re: 2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help! [In reply to] Sign In

Expensive area where I am and that's still out of control pricing!

T
_________________________________________
Long retired now


sh0wtym3
New User

Jul 11, 2012, 2:46 PM

Post #5 of 6 (2965 views)
Shortcut
Re: 2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help! [In reply to] Sign In

Right? Way too expensive, and I don't think I trust the dealership mechanic

I'm going to take it to a transmission specialist and see what he says, I found an honest one that's pretty close by


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jul 11, 2012, 3:24 PM

Post #6 of 6 (2962 views)
Shortcut
Re: 2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help! [In reply to] Sign In

Sounds like a plan. Still far from free but can't imagine what ##'s you mentioned above,

Tom
_________________________________________
Long retired now




2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help!


  Email This Post
 
 






Latest Forum Post

I had the valve covers off and noticed one side was grimy and greasy, and the ot...


My 1996 chevy silverado 4x4 5.7 ltr. is running weird sometimes. the problem is ...


Hi Guys, Girlfriend and I went on vacation in her 2005 escape. We get to a moder...


good morning all.. needing advice. 2008 toyota sequoia 130,000 miles 8 weeks ag...


2000 Nissan Maxima VQ30DEK (3 liter V6), just hit 170k miles. Relevant history...


2009 Jetta: My blower and cigarette lighter are not working. I've traced the sch...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics