Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN







2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help!


  Email This Post



sh0wtym3
New User

Jul 10, 2012, 9:47 PM

Post #1 of 6 (2289 views)
Shortcut
2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help! Sign In

2003 Chrysler 300M
3.5L V6 engine
111304 miles

Hey everyone,

When I first start to drive my car its fine, but often when I decelerate (especially when decelerating fast or going up an incline) the engine will jerk and then remain in 2nd gear until I turn it off and back on again. I read online that this is called "limp-in" mode, and is a safety feature when something is going wrong. However when I drive the car in "autostick" mode, this doesn't happen nearly as often.

I took the car to my local dealership and they said they didn't know what the problem was, and they said they needed to take the transmission apart ("transmission overhaul") to find out what parts are needed. This will cost me $1,682.69 which I don't have, plus the cost of labor and whatever part needs to be replaced. Then below that quote they wrote "this does not include R&R complete transmission assembly fee - $3524", which I'm guessing means they are going to charge me another arm and leg to put it back together!

Do I really need a transmission overhaul? Is there some cheaper alternatives I can try to fix it? Here are the error codes along with the notes the technician wrote down:

P0562 - "Low battery"
P0952 - "Auto stick input circuit low"
P0731 - "Gear ratio error in 1st"
P1790 - "Fault immediately after shift"
P0841 - "LR pressure switch sense circuit"
P0871 - "Overdrive pressure switch sense circuit"
P1776 - "Solenoid switch valve located in LR position"

Any help would be much appreciated!


(This post was edited by sh0wtym3 on Jul 10, 2012, 9:48 PM)


Hammer Time
Ultimate Carjunky / Moderator


Jul 10, 2012, 9:58 PM

Post #2 of 6 (2282 views)
Shortcut
Re: 2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help! [In reply to] Sign In

Even if you do, you can get it done a lot cheaper than that. Use references to find a reputable independent transmission shop.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



nickwarner
Veteran / Moderator


Jul 10, 2012, 11:20 PM

Post #3 of 6 (2242 views)
Shortcut
Re: 2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help! [In reply to] Sign In

Agree with HT. The price is way too high. Shop around. I think you do need a trans especially with 2 of the codes in that list but no reason it should cost that much.


Tom Greenleaf
Ultimate Carjunky / Moderator


Jul 11, 2012, 6:14 AM

Post #4 of 6 (2226 views)
Shortcut
Re: 2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help! [In reply to] Sign In

Expensive area where I am and that's still out of control pricing!

T
_________________________________________
Long retired now


sh0wtym3
New User

Jul 11, 2012, 2:46 PM

Post #5 of 6 (2207 views)
Shortcut
Re: 2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help! [In reply to] Sign In

Right? Way too expensive, and I don't think I trust the dealership mechanic

I'm going to take it to a transmission specialist and see what he says, I found an honest one that's pretty close by


Tom Greenleaf
Ultimate Carjunky / Moderator


Jul 11, 2012, 3:24 PM

Post #6 of 6 (2204 views)
Shortcut
Re: 2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help! [In reply to] Sign In

Sounds like a plan. Still far from free but can't imagine what ##'s you mentioned above,

Tom
_________________________________________
Long retired now




2003 Chrysler 300M keeps getting stuck in "limp-in" mode. Help!


  Email This Post
 
 






Latest Forum Post
Hi, I have a '99 Passat that is 50/50 on getting into traffic thanks to the occa...
I owe a 1992 Dodge Spirit. I have maintained the car as best I could over the y...
1997 Geo Metro 1.3 liter 100,000 miles Hello, my 97 geo metro keeps shuttin...
I have a 2007 Ford Explorer sport trac 4.0 engine- everytime I start it I hear t...
Year of vehicle Make of vehicle (Ford/ Chevrolet) Model of vehicle ( Taurus...
Hey everyone I am new here to the forums but I desperately need some advice, I u...

Feed Button


Used Car Search
Used Car Price Ranges:
Under $5,000
$20,000
$35,000

$10,000
$25,000
$40,000
$15,000
$30,000
$45,000
Over $45,000
Search used Cars By Manufacturers:
Used Acura
Used Audi
Used BMW
Used Buick
Used Cadillac
Used Chevrolet
Used Chrysler
Used Dodge
Used FIAT
Used Ford
Used GMC

Used Honda
Used Hyundai
Used Infiniti
Used Jaguar
Used Jeep
Used Kia
Used Land Rover
Used Lexus
Used Lincoln
Used Mazda
Used Mercedes-Benz

Used MINI
Used Mitsubishi
Used Nissan
Used Porsche
Used Saab
Used Scion
Used Subaru
Used Suzuki
Used Toyota
Used Volkswagon
Used Volvo
2010 Honda Civic
$15,770
2004 Jeep
$8,991
2012 Mustang
$22,990
1997 Honda Cr-V
$4,490
2010 Toyota Prius
$17,496
2010 BMW 328
$26,980




Automotive Forum Categories
Automotive Repair
Auto Body Repair and Refinishing
AC Auto Repair Help Forum
Automotive Wiring and Electrical

Auto Insurance and Car Financing
Automotive World
Brake Systems
Car Stereo Repair Advice
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair

Steering and Suspension
Tricks of the Trade
General Discussions
Car Shows and Events
The Bargin Bin
Motor Vehicle Inspection
Car Care Tips
Traffic Ticket Help
Car Racing

Gasoline, Motor Oils, Concept Cars
Remote Control Cars and Vehicles
Truck Repair
Truck Repair Advice


Truck Engine Repair
Truck Suspension Repair
Motorcycle Repair
Motorcycle and ATV Repairs

Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Seat Repair
Car Forum Posts - Sitemap


Search for (options) Privacy