Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

2000 Ford Escort will not start


  Email This Post



deathtomayo
New User

Sep 30, 2012, 4:53 PM

Post #1 of 2 (1855 views)
2000 Ford Escort will not start Sign In

2000
Ford
Escort ZX2
4 Cyl 2.0L
90,000 mi (give or take)

Last night my car stopped running and I was forced to get it towed home. I stopped at a red light and noticed smoking coming out from the hood. I managed to get the car to the side of the road and though I put water and coolant in the coolant tank, the tank was empty and the radiator was bone dry. The car is not starting and is producing a rough grinding noise with any attempts (I'm not sure how else to describe it. If posting a video of the sound would be of help, I can do that.) A friend suggested that the pistons don't sound like they are moving while my stepfather said that may not be the case as the "crank" was moving.

I have replaced the O2 sensor little more than a year ago as suggested by a digital diagnostic and a few months ago replaced the PCV hose for the same reason. I have had a couple of instances with overheating but only very recently. Any help is greatly appreciated. Thank you.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 30, 2012, 4:59 PM

Post #2 of 2 (1839 views)
Re: 2000 Ford Escort will not start Sign In

You probably just learned a very expensive lesson. You drove it too how and probably fried the engine now. Fix the coolant leak first and see what you have.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



(This post was edited by Hammer Time on Sep 30, 2012, 5:00 PM)






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap