Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

1997 Nissan Altima no fuel to engine


  Email This Post



NSSWEENEY
New User

Aug 2, 2013, 9:56 AM

Post #1 of 2 (879 views)
1997 Nissan Altima no fuel to engine Sign In

1997 Nissan Altima, 2.7L, 130k miles

I recently moved to Texas and this car was sitting in our driveway for about six weeks without being used. I drove it about four miles to get some food. When I got back to my car It wouldn't start, but after waiting a couple minutes it started right up. I had one more stop to make, and after this stop it started right up the first time. I drove home, parked it in our driveway, and didn't drive it for two days. After that I tried starting it, but no luck. I happened to have starting fluid, so I sprayed some in my air intake, and it started right up and died. Suspecting a fuel problem I disconnected the fuel filter to see if gas was getting that far. There was gas in the filter, but not in the hose, and there was no pressure. I went ahead and changed the fuel filter at this time. I suspected the relay might be bad so I switched the fuel pump relay with the radiator fan relay (identical relays) but still not luck. I'm thinking fuel pump, but is there any way to make sure I'm heading in the right direction?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Aug 2, 2013, 9:58 AM

Post #2 of 2 (875 views)
Re: 1997 Nissan Altima no fuel to engine Sign In

You need to test for power and ground arriving at the pump during the first 2 seconds of "key on" and while the engine is cranking.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap