Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

1992 Chevrolet S-10 cuts off when air condition or heater is turned on


  Email This Post



Nathan Scott
User

Jan 6, 2014, 6:41 AM

Post #1 of 23 (1251 views)
1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

I have a 1992 Chevrolet S-10 pickup truck with a 4.3L V6 that will crank up but idles really low. When putting in gear the truck almost cuts off, however if you turn the air condition or heater on the truck will die right down and cut off. I have replaced the idle air control valve, the EGR valve, the map sensor, and the tps. What am I missing? Please help!


kev2
Veteran
kev2 profile image

Jan 6, 2014, 7:27 AM

Post #2 of 23 (1236 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

  This is a 4.3L with a TBI - a very easy to work system without a scanner- the BASICS will apply and can be easily checked.
Charging system - battery good alt putting out?
have you checked for codes- OBDI system is limited BUT a start.
The CEL - does it come on at every start @2 seconds then go out?

Basics- plugs- spark- VACUUM- fuel pressure- (can see the injectors pattern) ,

I am guessing there is 1) charging issue, 2) CODE


Nathan Scott
User

Jan 6, 2014, 8:11 AM

Post #3 of 23 (1226 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

It turns over and starts right up. I haven't check for codes as I don't have the necessary tools to do so. As for the CEL, I have no idea what that is, I'm a rookie at working on automobiles! This truck was giving to me by my father-in-law. It has 238,000 miles on it. It ran good when I got it from him, however, trying to do good by the truck that was giving to me I put Sea Foam cleaner in the gas tank, thinking I was doing a good thing but ever since I used the Sea Foam it has not ran right. It immediately began idling lower. Could that be the problem?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jan 6, 2014, 8:26 AM

Post #4 of 23 (1223 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

Have you burned through that tank of fuel yet?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Nathan Scott
User

Jan 6, 2014, 8:31 AM

Post #5 of 23 (1218 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

Yes sir, many times over, I have even tried other injector cleaners, fuel additives, etc. but nothing has worked so far. I did find a broken gasket under the injectors where it attaches to the throttle body.


DanD
Veteran / Moderator
DanD profile image

Jan 6, 2014, 8:36 AM

Post #6 of 23 (1218 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

CEL = Check Engine Light or Service Engine Soon Light

You can get what is called flash codes from this year of vehicle.
Jumper the terminals that are shown in the diagram below.
You'll find this connector under the left (driver's) side of the dash.
You count the flashes for example a code 24 would be 2 flash and pause and then 4 flashes. Each code will repeat itself 3 times.
Once you find the connector install the jumper wire (Steel paper clip works fine), then turn the ignition to the run position with out starting the truck.
The check engine light should begin flashing codes.



Dan.

Canadian "EH"






Nathan Scott
User

Jan 6, 2014, 8:41 AM

Post #7 of 23 (1214 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

Ok I'll try this then I'll let you know what I get. Thanks for all your help


Nathan Scott
User

Jan 6, 2014, 9:22 AM

Post #8 of 23 (1209 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

I'm getting two different set of blinks the first one is dot-dot,dot; the second is dot ,dot-dot,dot or if you will, blink-blink,blink; the second is blink,blink-blink,blink. I don't know what they mean but that is what it is doing!


DanD
Veteran / Moderator
DanD profile image

Jan 6, 2014, 10:39 AM

Post #9 of 23 (1199 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

If you read it correctly that would be a code 34 MAP voltage low.
With the engine running make sure the MAP sensor has vacuum being supplied; that the line is not cracked and leaking vacuum.
If that is OK; disconnect the MAP wiring harness and jumper terminals B &C (I think the light gray wire and the gray wire); the connector should be marked ABC. Start the engine and do what you have to to keep it running.
Shut it off after a few minutes and recheck codes. If you have a code 33 now; that will tell us that the ECM (computer) and wiring is OK for that circuit; replace the sensor.




Sorry for the size of the images any smaller for the component locator and I couldn't read it.

Dan

Canadian "EH"






Nathan Scott
User

Jan 6, 2014, 10:48 AM

Post #10 of 23 (1189 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

Thanks I'll try it out and will get back to you as soon as I can.


Nathan Scott
User

Jan 6, 2014, 10:52 AM

Post #11 of 23 (1186 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

Also, how do I check to see if it is getting any vacuum?


DanD
Veteran / Moderator
DanD profile image

Jan 6, 2014, 11:29 AM

Post #12 of 23 (1181 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

With the engine running pull the vac line off the sensor and put your finger over the end. You'll likely have to play with the throttle to keep the engine running.
There should be enough vacuum to just hold the line to your finger.

Dan.

Canadian "EH"






(This post was edited by DanD on Jan 6, 2014, 11:30 AM)


Nathan Scott
User

Jan 6, 2014, 11:31 AM

Post #13 of 23 (1177 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

It is flashing 3 times pause then 4 times


Nathan Scott
User

Jan 6, 2014, 11:33 AM

Post #14 of 23 (1174 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

It is now flashing a sequence of 3 times then 4 times


DanD
Veteran / Moderator
DanD profile image

Jan 6, 2014, 11:35 AM

Post #15 of 23 (1171 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

OK code 34?
Which of the other test have you done?????
Dan.

Canadian "EH"






Nathan Scott
User

Jan 6, 2014, 11:38 AM

Post #16 of 23 (1163 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

I took the wire harness off of the map sensor and ran it like you said. I also checked for vacuum and it does have vacuum going to the map sensor


Nathan Scott
User

Jan 6, 2014, 11:45 AM

Post #17 of 23 (1160 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

When I took the hose off of the map sensor the truck idled up but when I put it back on the truck idled right back down to just about nothing.


Nathan Scott
User

Jan 6, 2014, 11:51 AM

Post #18 of 23 (1157 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

When I first turn the ignition switch on it flashes 1 then pauses and flashes 2 times. Then it flashes 2 times pause then 2 more times then it goes to 3 flashes pause then 4 flashes


DanD
Veteran / Moderator
DanD profile image

Jan 6, 2014, 12:26 PM

Post #19 of 23 (1152 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

The code 12 tells us that you are in diagnostics
Code 22 is the TPS circuit voltage low
Code 34 is MAP voltage low.
I was wondering when you were going to post code 12; because if you didn't; I'd know you were doing something wrong.
You're going to have to start doing some meter testing.
Or throw in the towel and take the truck in.
I'll be off line likely until tomorrow.
Gather all your thoughts, organize them and then post a detailed list of things you've tested along with the results.
Remember I'm not there to see what you've just finished doing. You have to tell me/us.

Dan

Canadian "EH"






Nathan Scott
User

Jan 6, 2014, 12:37 PM

Post #20 of 23 (1145 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

Thanks for all the help, I will keep you posted


kev2
Veteran
kev2 profile image

Jan 6, 2014, 1:47 PM

Post #21 of 23 (1139 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

  the 2 codes TPS ad MAP both low voltage... using the great picture of the map sensor to guide you see if you have 5v at the sensor, same for the TPS... Next check the ground portion of the sensors, like I said an easy system to work and being so common lots of tips developed over the years.


Nathan Scott
User

Jan 7, 2014, 12:09 PM

Post #22 of 23 (1111 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

Both sensors are registering 6V. How do I check the ground?


kev2
Veteran
kev2 profile image

Jan 7, 2014, 3:09 PM

Post #23 of 23 (1105 views)
Re: 1992 Chevrolet S-10 cuts off when air condition or heater is turned on Sign In

using a DVOM one lead grounded the other probe the ground circuit... should show continuity NOT open
Plan B with KOEO probe and post the signal voltage -

A DVOM is used to be overly cautious when working circuits that terminate at the vehicle computer...






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap