Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




1990 Jeep Wrangler won't start!!! Help!!!


  Email This Post



pkstanley
New User

Dec 14, 2009, 4:00 PM

Post #1 of 2 (2030 views)
Shortcut
post icon 1990 Jeep Wrangler won't start!!! Help!!! Sign In

I have a 1990 Jeep Wrangler. A few days ago when I would go to start it it sounded like to was sluggish to start...then yesterday I went to start the jeep and nothing! No sound at all...last week I left the lights on and the battery went dead, but its a pretty new battery, and all the lights and radio and noises inside the car come on when I try and start it so I don't think its the battery. I tried cleaning the battery terminals and jump starting too but nothing happens. Now all I can hear when I try to start it is one click. And I can hear what sounds to be like a pump. Can anyone tell me what this could be? I'm in desperate need and don't have a lot of money...so if anyone has an idea of what this could be please let me know???????


(This post was edited by Sidom on Dec 14, 2009, 9:42 PM)


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Dec 15, 2009, 9:50 AM

Post #2 of 2 (2007 views)
Shortcut
Re: 1990 Jeep Wrangler won't start!!! Help!!! [In reply to] Sign In

It hard on a battery to go dead and takes life out of it. You also need to clean the other ends of the cables. If with a jump you get one click they probably are bad at the other end - starter and engine block,

T
_________________________________________
Long retired now




Advertising


  Email This Post
 
 






Latest Forum Post

Just bought a 2000 buick century with 74K miles. it has a v-6 motor. service s...


I have 2001 ford explorer 140,000 miles,2yrs ago i replaced the fuel pump and ju...


Hey! I recently got my beloved VW Mk3 Golf 1.4L 1996 (N) MOT'd, I was considerin...


1996 mercury cougar xr7 coupe 3.8 127,000 Hi there, last night I was hit in the...


1998 Chevy 3500,6.5 diesel,automatic trans,4WD,1ton dump truck. Problem:Driving ...


I have a 2006 Honda Accord EX 4 door Sedan 4cyl motor automatic trans 155,000 mi...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy