Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

07 trailblazer Heat not always working


  Email This Post



jprimo825
New User

Dec 5, 2014, 10:15 AM

Post #1 of 3 (828 views)
07 trailblazer Heat not always working Sign In

I have an 07 chevy trailblazer and the heat stopped working. I replaced the resistor the other day and it worked great. This morning it was very cold outside and the heat would not work again. I went out lunch time and it wasn't working at first then all of a sudden it came on and worked great. What is making it do this? Thanks


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Dec 5, 2014, 10:36 AM

Post #2 of 3 (820 views)
Re: 07 trailblazer Heat not always working Sign In

You mean the blower doesn't blow air? Try this next time it's definitely down and should be working: Tap on the body of the motor (don't smash it) with a hammer, plastic hammer or hammer with an extension of metal and if it snaps right into working instantly that suggests a high chance that the motor is no good.


Since you did a resistor it sounds like you might do a motor if needed. Just note some or many may use a REVERSE THREADED nut holding the "squirrel" cage on typical types. Check threads on the replacement if unsure that may be available with or without the cage or nut - can't know that for your choice of a replacement but test as much first so it's not just a waste,


T



jprimo825
New User

Dec 5, 2014, 12:03 PM

Post #3 of 3 (806 views)
Re: 07 trailblazer Heat not always working Sign In

Ok, Thanks Tom






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap