Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

Cat issues? Looking for a second opinion


  Email This Post



Alfa 89
Novice

Oct 12, 2017, 7:44 PM

Post #1 of 2 (115 views)
Cat issues? Looking for a second opinion Sign In

Hi all! Ill try and keep this brief. I was given an 2008 impreza 2.5i(non turbo) with the CEL on and its got some issues. It is very underpowered and accelerates like crap, cant get it it to go over 65mph or shift into 5th even in manuel mode rpm wont rev above 5000. I also discovered an exhaust leak on the flange where the headers connect to the lower pipe maybe 6-8in from the downstream 02 sensor, It's showing the following codes.
P0137- O2 sensor circuit low voltage(bank1 sensor2)
P2096- Post Catalyst fuel trim system too lean (Bank 1)
P0140- O2 sensor circuit range/performance(Bank1 sensor2)

The old owner mentioned he had an aftermarket cat on that the ecu didn't like and the cel had been on for a while. So here's what I'm thinking and I would love a second opinion. The exhaust leak caused a false lean reading from the O2 sensor causing the engine to run rich and clogged up the cat, hence the crappy acceleration. Also because of the cat there's not enough pressure to get the car to shift into 5th or go above 5000rpm.
So to correct this I plan to at least replace the headers/cat with Bosal headers, the 02sensors, and the leaking flange gasket. Does anyone else think this is the way to go, or have any other ideas/suggestions? Thanks a bunch in advance!


Alfa 89
Novice

Oct 16, 2017, 5:34 AM

Post #2 of 2 (73 views)
Re: Cat issues? Looking for a second opinion Sign In

Guess I'll answer my own question hopefully for someone elses benefit. I replaced the headers, rear 02 sensor, and fixed the exhaust leak coming from the flange. That cat was indeed very plugged up. But the problems actually got worse. So i cut a 1/2 piece of the exhaust off right before the downstream cat and problem solved, it seems both cats were plugged up. I'll have to replace the lower exhaust at some point. As for the car not shifting into 5th.... That's because its a 4 speed 😳. Thanks for all the help.






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap

shopify
site analytics