Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









truck backfires no power


  Email This Post



wranglerman
Novice

Nov 27, 2010, 7:22 PM

Post #1 of 7 (707 views)
Shortcut
truck backfires no power Sign In

UnsureUnsureUnsurehi i have a 1987 chevy wrangler pick up with a 5.7 engine the km are 326874 on truck not exactly sure on rebuild but was told around 50000km. The problem is the motor back fires through the tbi. Yes i have checked the timing its fine but also iv noticed the lights dim when this happens the motor seems to also lose power than the lights brighten and also the power p[cks up. Was wondering if problem could be in the computer or maybe the advance in the distributor maybe there is a sensor that sends a signal to the computer to advance the timeing????? this i dont know can some one please help me


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 27, 2010, 7:42 PM

Post #2 of 7 (696 views)
Shortcut
Re: truck backfires no power [In reply to] Sign In

Check all you power supply points like the battery cables, power distribution points (starter), fuse boxes and ignition switch. Look for contacts that have been overheated and are no longer making a good contact.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



(This post was edited by Hammer Time on Nov 27, 2010, 7:42 PM)


wranglerman
Novice

Nov 27, 2010, 7:52 PM

Post #3 of 7 (689 views)
Shortcut
Re: truck backfires no power [In reply to] Sign In

thanks for replying i have checked the power points found the post on starter solinoid had worn down so i was able to rotate it and get a good contact.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Nov 27, 2010, 7:55 PM

Post #4 of 7 (685 views)
Shortcut
Re: truck backfires no power [In reply to] Sign In

We're not talking about starter operation here. we're looking at operating power which feeds from the fusible links at the starter.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



wranglerman
Novice

Nov 27, 2010, 8:07 PM

Post #5 of 7 (681 views)
Shortcut
Re: truck backfires no power [In reply to] Sign In

well as i said i checked for any thing that didnt seem right but realy didnt find anything. WAS thinking may be the voltage regulator had the service engine light come on but had it read and apparently it was a code 12 ?? was told probly bacause the ac ahs been disconnected???


wranglerman
Novice

Nov 28, 2010, 4:43 PM

Post #6 of 7 (670 views)
Shortcut
Re: truck backfires no power [In reply to] Sign In

ok i rechecked all my power points the only thing i have out of the ordinary is the delay on my wipers dont work could this possibly cause a problem?????
sorry did not realize you could only post once! as i had asked is there some sort of sensor for cold start ups as i have noticed when it gets colder the problem gets worse untill the truck warms up??? once again i appoligize


(This post was edited by wranglerman on Dec 2, 2010, 9:37 AM)


weezer
Novice

Dec 2, 2010, 10:45 PM

Post #7 of 7 (648 views)
Shortcut
Re: truck backfires no power [In reply to] Sign In

Don't know about lights dimming,
or temp loss of power, but a flat camshaft lobe
can cause backfire especially when accelerating.




Advertising


  Email This Post
 
 






Latest Forum Post

hi everyone I was vacuum testing an engine and when I wide open the throttle th...


My Dad passed away and we need to sell his 1936 Auburn boat tail speedster. No i...


I recently replaced the brake lamp switch in my 2001 Dodge Caravan. Now the bra...


Hi,here's the info,hope a few members can help me please Car 1998 Olds int...


hey there folks. So i just bought my first car for $600. it was saftied and came...


My question is regarding a problem with an 03 Infiniti G35 with 5 speed automati...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy