Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









engine surging


  Email This Post



jtbredow
New User

Jun 23, 2007, 9:48 PM

Post #1 of 3 (842 views)
Shortcut
engine surging Sign In

Hello all,

I own a '97 Chevy Lumina with approx. 125,000 miles and the 3.1L engine. I'm looking for ideas regarding some engine surging I've started experiencing. It only happens when I'm accelerating between 50-70 mph (but especially between 50-60) or if the car is on cruise in that range and I'm going up a hill - so essentially when I have to give it some gas between 50-70 mph. If I really step on the accelerator I don't notice it and it doesn't happen all the time, but it is a majority of the time and seems to be getting worse. The surging isn't really violent and jerky, but definitely noticeable. Is it something with the fuel pump and/or filter?

Thanks in advance for your help!

jtbredow


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jun 28, 2007, 7:00 AM

Post #2 of 3 (820 views)
Shortcut
Re: engine surging [In reply to] Sign In

It wouldn't hurt to get a new fuel filter and perhaps a fuel pressure check may show that it's on the low side of pressure. Hard to say right now but rule out the obvious like tune-up items that could be due. Plugs are a pest on those cars and many others for that matter,

T
_________________________________________
Long retired now


jtbredow
New User

Jun 28, 2007, 10:18 PM

Post #3 of 3 (817 views)
Shortcut
Re: engine surging [In reply to] Sign In

Thanks for the feedback, Tom. I did have the plugs & wires replaced at 104k miles and the fuel pressure regulator was replaced at 110k miles. I'm due for an oil change soon, so I'm going to have my mechanic check it out. I figured it's the fuel filter, but wanted some ideas on what else it could be.

Thanks!

jtbredow




engine surging


  Email This Post
 
 






Latest Forum Post

My 96 Camry SV40 has an amron battery just 2 years old. Now it sometimes does no...


gearheads.....the car is a toyota 22re......i gave it a try to look down the the...


I am having a problem with my wife's Ford 2003 Escape. I went down to get the c...


I have an 89' chev. suburban 4x4 that the upper gears is out. I also have a 90'c...


Hi! I have a 2002 Dodge Stratus, 2.4L DOHC with about 253,000 miles. The CEL is ...


Hi guys this is my friend's 04 civic one head light bulb keeps blowing, the fuse...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics