Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









engine surging


  Email This Post



jtbredow
New User

Jun 23, 2007, 9:48 PM

Post #1 of 3 (902 views)
Shortcut
engine surging Sign In

Hello all,

I own a '97 Chevy Lumina with approx. 125,000 miles and the 3.1L engine. I'm looking for ideas regarding some engine surging I've started experiencing. It only happens when I'm accelerating between 50-70 mph (but especially between 50-60) or if the car is on cruise in that range and I'm going up a hill - so essentially when I have to give it some gas between 50-70 mph. If I really step on the accelerator I don't notice it and it doesn't happen all the time, but it is a majority of the time and seems to be getting worse. The surging isn't really violent and jerky, but definitely noticeable. Is it something with the fuel pump and/or filter?

Thanks in advance for your help!

jtbredow


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jun 28, 2007, 7:00 AM

Post #2 of 3 (880 views)
Shortcut
Re: engine surging [In reply to] Sign In

It wouldn't hurt to get a new fuel filter and perhaps a fuel pressure check may show that it's on the low side of pressure. Hard to say right now but rule out the obvious like tune-up items that could be due. Plugs are a pest on those cars and many others for that matter,

T
_________________________________________
Long retired now


jtbredow
New User

Jun 28, 2007, 10:18 PM

Post #3 of 3 (877 views)
Shortcut
Re: engine surging [In reply to] Sign In

Thanks for the feedback, Tom. I did have the plugs & wires replaced at 104k miles and the fuel pressure regulator was replaced at 110k miles. I'm due for an oil change soon, so I'm going to have my mechanic check it out. I figured it's the fuel filter, but wanted some ideas on what else it could be.

Thanks!

jtbredow




engine surging


  Email This Post
 
 






Latest Forum Post

Greetings from cooking hot and humid SW Florida. Been getting lot's of help her...


2006 Jeep Grand Cherokee Laredo 6 cyl. 90,000 miles Has had some interesting s...


I have a 2001 Dodge Neon that I use for as a work vehicle. The brake light came ...


Hi there, So I have a Mazda protege 1.6L engine Year 2000. I am getting the f...


I had the valve covers off and noticed one side was grimy and greasy, and the ot...


My 1996 chevy silverado 4x4 5.7 ltr. is running weird sometimes. the problem is ...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics