Main IndexAuto Repair Home Search Posts SEARCH
Who's Online WHO'S
Log in LOG

blazer low power code P0101

  Email This Post


Dec 26, 2010, 5:44 PM

Post #1 of 3 (4808 views)
blazer low power code P0101 Sign In

chevy blazer 4.3L 1999 code P0101 replaced maf still same problem.......low power under load and if go up steep hills bogs down and bucks and goes real slow.scan tool shows 2,000hz idle and 4,000hz under load.volts will show .67 idle and up to 7-8 volts under load.If unplug maf runs better and shifts better but still problem going up steep hills but better on flats.any ideas would be appreciated.all scan tool info I have relates to gps but scan tool only shows volts and frequency.Maybe defective maf?

Veteran / Moderator
Sidom profile image

Dec 26, 2010, 8:25 PM

Post #2 of 3 (4800 views)
Re: blazer low power code P0101 [In reply to] Sign In

Check your vacuum and idle and high rpm. If possible check your backpressure. I've seen restricted exhaust systems give funky MAF readings before.

It's possible to get a bad MAF, sure wouldn't be the 1st time, frequency is probably the best way to test a MAF (that & fuel trims) but I'm more familiar with gps. What can I say.....old phart, old school........

What type of scan tool are you using? I know what type of scope you have.....



Dec 26, 2010, 9:58 PM

Post #3 of 3 (4795 views)
Re: blazer low power code P0101 [In reply to] Sign In

it responds fast at snap throttle.The check engine light went out before test drive.I have a autoenginuity pc base scan tool.My old snap on did gps.It is listed in my alldata at gps.Also was looking at map but not listed on scan data because vcm uses map to see if maf is working.Maybe map is defective.....have to manually test with vacuum pump and voltmeter.maybe hook up a fuel pressure gauge and take for a test ride.

blazer low power code P0101

  Email This Post

Latest Forum Post

I have a 86 Ford Bronco with a 302 engine and need a new carb. It is a 2 barrel ...

Does this car have a factory 3.5 mm audio input that I can use for an mp3 player...

Hi everyone is it hard to replace a blower motor on Volvo C70 2007


2002 suzuki xl7, 2.7, 4x4, a/c, a/t, 192,000 miles Wonderful car, we just inheri...

I have a 2010 Chrysler town & country 3.8 with 62000 miles. I am having rear...

Feed Button

Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap

Search for (options) Privacy

web statistics