Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




Intermittent rough engine performance Miata


  Email This Post



KenWagnerRealtor
New User

Jun 23, 2009, 10:38 AM

Post #1 of 2 (1171 views)
Shortcut
post icon Intermittent rough engine performance Miata Sign In

Hi Folks!

I have a 93 Mazda Miata with a 1.6l and 5 speed stick. The odometer stopped working at 164k a few years back. Otherwise it normally runs great! zoom zoom

So, lately the engine started stumbling a bit and then would run fine after just a couple of minutes. However this morning it was a bit worse and ran rough for about 5 minutes.
I've now added fuel injector cleaner, and I will be changing spark plugs and fuel filter later today.
The plug wires all appear to be in good shape and this problem is just intermittent right now.

Any ideas?

Any replys are appreciated!

Ken


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jun 23, 2009, 11:54 AM

Post #2 of 2 (1166 views)
Shortcut
Re: Intermittent rough engine performance Miata [In reply to] Sign In

 You may have a bad IAC ( idle air control) but try cleaning the throttle body first. Remove the intake snorkel, have someone hold the throttle wide open for you and scrub the back side of the throttle plate and surrounding bore with an old tooth brush and some carb cleaner. Be sure to spray some into the small holes next to the throttle plate. That should help stabilize the idle. If it still has a problem, replace the IAC.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.





Intermittent rough engine performance Miata


  Email This Post
 
 






Latest Forum Post

Mercedes C200 Classic W202 (V reg.)Took the battery out for an indoor charge but...


I just got a 2011 Ford Ranger,Idon't know if I have 1 problem or 2.The blower fa...


So, we have a 2002 Hyundai Elantra 2.0L automatic, non-ABS with 70,000 miles on ...


I'm doing the front brakes on my 1990 BMW 325i. The passenger side was wearing v...


My 87 motor home wont start unless gas is poured into carburetor. I replaced th...


I have a 1988 Dodge D100 318 and I just had new timing put in all new plugs spar...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics