Main IndexAuto Repair Home Search Posts SEARCH
Who's Online WHO'S
Log in LOG

High Idle on startup

car parts image

  Email This Post

New User

May 17, 2012, 3:23 PM

Post #1 of 3 (3044 views)
High Idle on startup Sign In

I have a 92 Grand Prix, 3.4L with 167,000 miles. My problem is when I first start it up it idles at around 3000 rpms.
Sometimes the rpms surge up and down. The weird thing is I can let it run like this for about 3 minutes and then
turn it off and wait 30 minutes and restart it and it will idle fine most of the time. Last year I replaced the tps and it
helped but now it's doing it again. Sometimes I can leave my foot off the gas pedal and it will get up to 50 mph by itself. I just put a new tps on it and it didn't help. If anyone has any suggestions I would really appreciate it.

Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

May 17, 2012, 3:56 PM

Post #2 of 3 (3017 views)
Re: High Idle on startup Sign In

If your check engine light is ever coming on, resolve those issues first.

You may have a bad IAC ( idle air control) but try eliminating any vacuum leaks and cleaning the throttle body first. Remove the intake snorkel, have someone hold the throttle wide open for you and scrub the back side of the throttle plate and surrounding bore with an old tooth brush and some carb cleaner. Be sure to spray some into the small holes next to the throttle plate. That should help stabilize the idle. If it still has a problem, replace the IAC.


We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.

New User

May 17, 2012, 4:11 PM

Post #3 of 3 (3005 views)
Re: High Idle on startup Sign In

Thank You so much. I did forget to mention that the Service Engine Light comes on when it idles high then goes
off when it idles normal. I will do these things you suggested and I thank you

  Email This Post

Feed Button

Search for (options) Privacy Sitemap

site analytics