Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









High Idle on startup


  Email This Post



Timb
New User

May 17, 2012, 6:23 PM

Post #1 of 3 (2380 views)
Shortcut
High Idle on startup Sign In

Hello,
I have a 92 Grand Prix, 3.4L with 167,000 miles. My problem is when I first start it up it idles at around 3000 rpms.
Sometimes the rpms surge up and down. The weird thing is I can let it run like this for about 3 minutes and then
turn it off and wait 30 minutes and restart it and it will idle fine most of the time. Last year I replaced the tps and it
helped but now it's doing it again. Sometimes I can leave my foot off the gas pedal and it will get up to 50 mph by itself. I just put a new tps on it and it didn't help. If anyone has any suggestions I would really appreciate it.
Thanks


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

May 17, 2012, 6:56 PM

Post #2 of 3 (2353 views)
Shortcut
Re: High Idle on startup [In reply to] Sign In

If your check engine light is ever coming on, resolve those issues first.

You may have a bad IAC ( idle air control) but try eliminating any vacuum leaks and cleaning the throttle body first. Remove the intake snorkel, have someone hold the throttle wide open for you and scrub the back side of the throttle plate and surrounding bore with an old tooth brush and some carb cleaner. Be sure to spray some into the small holes next to the throttle plate. That should help stabilize the idle. If it still has a problem, replace the IAC.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Timb
New User

May 17, 2012, 7:11 PM

Post #3 of 3 (2341 views)
Shortcut
Re: High Idle on startup [In reply to] Sign In

Thank You so much. I did forget to mention that the Service Engine Light comes on when it idles high then goes
off when it idles normal. I will do these things you suggested and I thank you




Advertising


  Email This Post
 
 






Latest Forum Post

 Had starter, alt, battery checked. Car starts great but will go completely...


 HotOil warning, from cold start, and won't start, Jeep JK wrangler 2010 un...


What is the cheapest fix availible along with estimated repair price and what wo...


hi everyone this is mazda tribute 200, the code is p1131 where should we start t...


Hi,here's the info,hope a few members can help me please Car 1998 Olds int...


Hi anyone: If you haven't left (by car) yet things you should really consid...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy