Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

Car wont stay running!!


  Email This Post



bonebreaker2u
New User

Mar 4, 2017, 1:10 PM

Post #1 of 2 (274 views)
post icon Car wont stay running!! Sign In

I have a 2000 Nissan Xterra, 6 cylinder. I was driving to work one day and the car just lost power, so i towed it to my house. This has be several months and i am at a lost... please help!!

Originally the car would not start at all, the code i got when hooking a computer to it was p340, cam shaft positioning sensor.

So i replaced the distributor since the cam shaft sensor is built into the distributor. The car would still not start... so then i replaced the ecm relay and boom! the car will start again..

Now this is were i am at, the car will not always turn over when i turn the key to the start position. When the car does start, i have to hold my foot on the gas to keep it running or it just stalls. I cleaned the throttle body and still nothing. I am not sure were to go next... please help :(


kev2
Veteran
kev2 profile image

Mar 4, 2017, 1:57 PM

Post #2 of 2 (262 views)
Re: Car wont stay running!! Sign In

what codes are there NOW?
Also will your scanner show live data? FT's, o2sensor voltages, etc?
holding foot on gas - might want to check fuel system, fuel pressure with a gauge then observe pressure leak down.






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap

shopify
site analytics