Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






Search Auto Parts

96 Cirrus cranks but doesn't start


  Email This Post



edwardra3
New User

Aug 17, 2015, 12:12 PM

Post #1 of 2 (550 views)
96 Cirrus cranks but doesn't start Sign In

I have a 96 Chrysler Cirrus, 4 cylinder, 2.4L with ~140,000 miles. The car leaks oil and transmission fluid but has otherwise run great for me.

In May, I parked the car in the garage where it has sat all summer. About 4 weeks in, I realized I wasn't going to have a chance to drive it for a while and put a float charger on it to keep the battery charged. Last week, I tried to start it. It cranks fine but nothing. I pulled the spark plugs and noted that they needed to be replaced. I also smelled gas on them. Thought maybe I flooded the engine trying to start it, so I let it sit.
This weekend, I picked up new plugs and wires and put them in. The old spark plugs stilled smelled like gas, particularly #4. New plugs and wires in and... still cranks but won't start.

Trying to buy a house this fall, so buying a car really isn't in the budget.


Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Aug 17, 2015, 5:28 PM

Post #2 of 2 (532 views)
Re: 96 Cirrus cranks but doesn't start Sign In

Have you checked for spark?





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap