Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




1998 Olds Intrigue low water warning light


  Email This Post



grayta
User

Aug 16, 2009, 11:59 AM

Post #1 of 2 (1900 views)
Shortcut
1998 Olds Intrigue low water warning light Sign In

I have a 1998 Olds Intrigue with a 3.8 liter V-6. I have a low water warning light that comes an, sometimes flashing, sometimes it stays on. The radiator is full, and the overflow is also close to full. I have used the bleeder screw on top of the thermostat and water comes out immediately. The car does not run hot, the temp gauge stays right about the middle of the gauge. I have flushed the cooling system using the heater hoses, and had clear water coming out of the inlet to the heater, and then I reversed the direction of flow and again had clear water coming out. I am just wondering if there is another bleeder located somewhere, or if this could just be a bad level sensor, and where I could locate it on the engine. Any help will be greatly appreciated. Thank You.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Aug 16, 2009, 12:20 PM

Post #2 of 2 (1897 views)
Shortcut
Re: 1998 Olds Intrigue low water warning light [In reply to] Sign In

Yes, that's probably just a bad level sensor. These sensors are known for this. It's located in the radiator.






~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.





1998 Olds Intrigue low water warning light


  Email This Post
 
 






Latest Forum Post

ok i have a 95 chevy z71 pick up truck. the problem i am having is when u get in...


I'm thinking of buying a totaled Nissan 370Z 2009. I already calculated the cost...


hello over the last week I have noticed iam losing water when returning to car o...


1999 Yukon Denali 5.7 250xxxkm . Shorted out starter to ground and then key does...


Hello to all of you from Az. This is my first post so I hope that I do it right,...


I have a 1974 Chev Nova with a 509/Turbo 400. 90k original mileage. Car is alwa...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics