Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




1998 Olds Intrigue low water warning light


  Email This Post



grayta
User

Aug 16, 2009, 11:59 AM

Post #1 of 2 (1861 views)
Shortcut
1998 Olds Intrigue low water warning light Sign In

I have a 1998 Olds Intrigue with a 3.8 liter V-6. I have a low water warning light that comes an, sometimes flashing, sometimes it stays on. The radiator is full, and the overflow is also close to full. I have used the bleeder screw on top of the thermostat and water comes out immediately. The car does not run hot, the temp gauge stays right about the middle of the gauge. I have flushed the cooling system using the heater hoses, and had clear water coming out of the inlet to the heater, and then I reversed the direction of flow and again had clear water coming out. I am just wondering if there is another bleeder located somewhere, or if this could just be a bad level sensor, and where I could locate it on the engine. Any help will be greatly appreciated. Thank You.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Aug 16, 2009, 12:20 PM

Post #2 of 2 (1858 views)
Shortcut
Re: 1998 Olds Intrigue low water warning light [In reply to] Sign In

Yes, that's probably just a bad level sensor. These sensors are known for this. It's located in the radiator.






~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.





1998 Olds Intrigue low water warning light


  Email This Post
 
 






Latest Forum Post

I have a 2007 Altima SE, 3.5. We have looked locally and online for a clutch dis...


2008 chevy uplander, 3.9 engine. One evening we notice air was not blowing cold....


98 Dodge Dakota ext cab. Haven't purchased yet, looking at tomorrow. If frame is...


2000 toyota tundra, 4.7L . Steering is very hard, as if pump is out. Replaced pu...


Hi I have 97 Chevy suburban K 1500 5.7. Didn't notice any pre symptoms before...


Also on the same ford I need to know if anyone knows what will make it run hot ...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics