Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

1993 Toyota 4Runner engine popping and sputtering only in forward gears at operating temp


  Email This Post



Bswopes
New User

May 8, 2020, 10:14 PM

Post #1 of 5 (388 views)
1993 Toyota 4Runner engine popping and sputtering only in forward gears at operating temp Sign In

I have a 1993 Toyota 4Runner with a 3.0 3vze 5 spd manual transmission it has 177,000 miles on it. I had this for a few years and haven’t had any issues until a week ago I just drove down to the gas station every thing fine started it back up to leave after putting some gas in and motor started popping and sputtering so I limped it home and checked for any codes and there was none so I went ahead and replaced the spark plugs plug wires and cap and rotor started up drove fine until it reached operating temp then started popping and sputtering again so noticed a pattern it drives fine until motor is at temp and runs great in neutral and runs great in reverse only in forward gears does it start to pop and sputter to date I have replaced the plugs cap and rotor plug wires the maf the coil and the o2 sensor and the egr also checked timing looked good at 10 btdc and advanced with throttle also Checked for vacuum leaks everything checked out good and did a compression test all 6 cylinders all within 3 psi of each other all right at 140psi so I’m tired of just throwing parts at it and would like some helpFrown so it runs great no issue until it reaches operating temp then only in 1st-5th will it start to pop and sputter and no power, but it will run great in reverse and neutral no issue? Thanks you for your time


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

May 9, 2020, 3:39 AM

Post #2 of 5 (368 views)
Re: 1993 Toyota 4Runner engine popping and sputtering only in forward gears at operating temp Sign In

You threw a lot parts at it and checked a lot of things but I didn't see anywhere that you tested the fuel pressure.

Also, if you have a single ignition coil they will often fail under load when they get hot.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Bswopes
New User

May 9, 2020, 7:25 AM

Post #3 of 5 (357 views)
Re: 1993 Toyota 4Runner engine popping and sputtering only in forward gears at operating temp Sign In

Ahh yes you are correct I will check those today would you know why it would run fine in reverse is there less load in reverse?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

May 9, 2020, 7:27 AM

Post #4 of 5 (355 views)
Re: 1993 Toyota 4Runner engine popping and sputtering only in forward gears at operating temp Sign In

No, very light throttle in reverse and lower gearing so no load.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

May 9, 2020, 10:19 AM

Post #5 of 5 (338 views)
Re: 1993 Toyota 4Runner engine popping and sputtering only in forward gears at operating temp Sign In

Bswopes: It does seem highly possible that it lacks BOTH enough pressure and volume when needed. Live view of it I'll let you figure out how to do for now.
A maybe reason is pump and I forget if this era of 4Runner used some "lifetime" idea of a fuel filter in fuel tank (never had the joy in person) to toss one just by chance now this is in the ancient club,


Tom







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap